Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have nvidia driver on both OSs. Same FF version. Both with smooth scrolling enabled. Using FF in windows is a big joy! It's so smooth, like a hot knife slicing butter. Ubuntu's FF is somewhat choppier. I realize this may be the driver as sometimes i see tearing in Ubuntu. I use v 11.10.

Am I the only one with such a problem?

share|improve this question
Goto about:config in Firefox on Windows and Linux, and check if 'general.smoothScroll' have the same value. – Anonymous Oct 26 '11 at 18:00

I was getting graphic lag as well, but with the Gnome Shell. I read on a forum that changing the driver would solve the problem and it did! Let us see if this can solve your problem as well.

  1. Open the Additional Drivers application.
  2. Select the recommended nvidia driver for usage.
  3. Follow the instructions issued by the application.

If I remember correctly, you will have to restart your computer in order for it to integrate the drivers into the kernel, and the next time you log in your problem might be solved.

share|improve this answer
Yes, i'm using that driver already. It doesn't help. – alex Oct 26 '11 at 18:49

You may also want to consider disabling IPV6 in Firefox. I find that this speeds my browsing experience up considerably. As an experiment, try loading Opera or Chromium to see if your browsing experience improves significantly. If it does, you way want to check out these directions -

share|improve this answer
I have FF7, and it's set to false. Thanks anyways! – alex Oct 27 '11 at 16:00
And? You need to set it to true... so that disableIPv6 is true and you have disabled it. – Vadim Oct 28 '11 at 23:32
I don't have any problems with loading content. I'm talking about scrolling. – alex Nov 6 '11 at 11:26
up vote 0 down vote accepted

Finally FF is smooth. And other graphic intense apps too. The recent xorg + unity update fixed it.

share|improve this answer
Actually, it still doesn't seem to be fast as windows, but at least better than it was. – alex Nov 6 '11 at 11:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.