Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My primary workstation runs the latest 11 workstation and my coworkers primary workstation runs the latest 10 LTS workstation.

He said that ssh tunneling is not working with ControlMaster (CM) and asked me to test, which I did and it worked fine. We then did a complete fresh install of 10.04 LTS on another box and sure enough ssh tunneling does not work with CM.

Example:

david@ubuntu:~/.ssh$ more config Host * ControlMaster auto ControlPath ~/.ssh/master-%r@%h:%p

ssh -l dingbat sshserver.host.com - enter my password

ssh -l dingbat sshserver.host.com -L 2222:another.host.com:22 - don't need to enter my password because of the control channel, which works fine...it just doesnt setup the tunnel on 10 LTS while it does on 11.

netstat -anp | grep 2222 - on 10 LTS there is no listening port while on 11 there is...and I couldn't find anything in the logs.

share|improve this question
add comment

1 Answer

There was a bug in openssh where slave connections could not pass new tunnel requests to the master connection. It was fixed in 5.4p1.

Ubuntu 10.04 LTS is currently on openssh 5.3, whereas Ubuntu 11.10 is on 5.8, so only the newer workstation will have the fix.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.