Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to tell Ubuntu One to sync with '~/Public/Ubuntu One' rather than '~/Ubuntu One'. Since I'm using it on Arch Linux, I don't have any right-click option for that.

I tried to edit ~/.config/ubuntuone/syncdaemon.conf and add the line root_dir = ~/new/folder (as suggested in this thread), but the file is automatically reverted to its previous state. Also, the command u1sdtool hangs and does apparently nothing - I have to use Ctrl + C to close it. Is there another way to setup the default Ubuntu One default local folder?

share|improve this question

4 Answers 4

To change the Ubuntu One default folder (tested in Ubuntu 12.04):

  1. Open /etc/xdg/ubuntuone/syncdaemon.conf as root

    comment out the following code:

    from root_dir.default = ~/Ubuntu One

    to # root_dir.default = ~/Ubuntu One

  2. Copy /etc/xdg/ubuntuone/syncdaemon.conf

    to ~/.config/ubuntuone/syncdaemon.conf

    with user attributes

  3. Open ~/.config/ubuntuone/syncdaemon.conf as user

    change the root directory wherever you want, e.g.:

    from # root_dir.default = ~/Ubuntu One

    to root_dir.default = ~/Public/Ubuntu One

  4. logout and log back in

It's done and working (at least for me)

(ubuntu 12.04 with Gnome and Unity)

General comments:

Playing with root_dir.default in /etc/xdg/ubuntuone/syncdaemon.conf is troublesome because changes become active for all users in the same machine.

Aside soft links doesn't really change de directory.

Finally, ability to change working directory from user interface should be standard if we want to make Ubuntu more user friendly for new linux users as a way to attract users from other systems (always preaching)

share|improve this answer

this is rather a comment (which i don't have the rights for yet) on fileubuntu's answer above (describing how) and hellpe's comment (of having the Ubuntu One folder reappear):

with 12.04 i managed to overcome the reappearance of the folder 'Ubuntu One' in my home-dir by

  • closing all nautilus instances (eventually showing shared folders and therefore somehow seem to keep restarting the u1sd)

plus

  • disabling the u1-sync-daemon through u1sdtool --quit

before

  • changing the root path in /etc/xdg/ubuntuone/syncdaemon.conf to one of my personal preference as described by fileubuntu.

afterwards i could remove the folder 'Ubuntu One' without having it come back ever after restarting the u1-sd through u1sdtool --start.

note that i did not want the folder 'Ubuntu One' to clutter up my /~ so i did not use the symlink variant described by BЈовић above.

share|improve this answer
    
Welcome to AskUbuntu! Thanks for pointing that this is a comment, please feel free to add it as a comment on the question as soon as you have the required reputation so it can be removed from the answers list. –  Oyibo Oct 2 '12 at 15:06

To change the Ubuntu One default folder (tested in Ubuntu 12.04):
Open /etc/xdg/ubuntuone/syncdaemon.conf as root and add/change the following code:
From root_dir.default = ~/Ubuntu One to root_dir = ~/new/folder, e.g. root_dir.default = ~/Online Storage/Ubuntu One. It tried to amend ~/.config/ubuntuone/syncdaemon.conf, but it gave me an error after a while.

Thanks to the post of Kleenux.

share|improve this answer

There is an easy way :

cd ~
rm -rf Ubuntu\ One
mkdir -p Public/Ubuntu\ One
ln -s Public/Ubuntu\ One Ubuntu\ One

This way you create a symbolic link of Ubuntu One directory to Public/Ubuntu One

share|improve this answer
    
Creating a symlink is not the same as having a different default folder. –  Greg Treleaven Oct 26 '11 at 19:52
    
That's the problem. I'm trying to make my home folder tidier, by keeping my Dropbox and Ubuntu One folders into the same "Public" folder (which is a FreeDesktop standard by the way). WIth a symlink, I still have an unwanted Ubuntu One folder icon in my home directory. –  hellpe Nov 8 '11 at 10:13
    
Some programs do not allow changing paths where they store configuration files. –  BЈовић Nov 8 '11 at 10:30
    
I've just found a workaround. You'll need a Ubuntu computer using your Ubuntu One account : - With the Ubuntu computer, create ~/Public and cut/paste the Ubuntu One folder into this Public folder. Don't forget to sync it. - With the non-Ubuntu computer (here, I've got Arch Linux), run the Ubuntu One control panel (ubuntuone-control-panel-gtk) then tick the ~/Public/Ubuntu One folder and untick the ~/Ubuntu One. - Theoretically, you should be able to delete the ~/Ubuntu One folder, since Ubuntu One is using ~/Public/Ubuntu One now. –  hellpe Nov 20 '11 at 23:33
    
There's still one issue : the ~/Ubuntu One folder keeps reappearing. It seems that you can't override the "Always synchronized" setting in the control panel. Is there a true way to disable ~/Ubuntu One syncing ? –  hellpe Nov 21 '11 at 19:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.