Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to Ubuntu 11.04, and have it set up with 4 workspaces. Most of the time I can switch between the workspaces without a problem using ctrl+alt+left/right/up/down, but at least once a day, I manage to hit some other combination that causes all of the windows to move to workspace 1 and resize all of the terminal windows. This is extremely frustrating because I have to stop what I was doing and move everything back where I had it and resize the windows again.

What combination of things is causing this to happen and how can I disable it?

Edit: I just had this happen after unlocking my screen as well, so it may not be directly related to switching my workspaces...

Edit (Jan 11, 2012): Updates are current as of earlier this week. .xsession-errors.old has a good amount of information in it, but I don't know what is significant and what is just noise, and it doesn't contain any timestamps, so I have no idea when what happened.

The last block of lines from .xsession-errors.old:

(indicator-multiload:1791): libappindicator-WARNING **: Unable to send signal for NewIcon: The connection is closed
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
nm-applet: Fatal IO error 104 (Connection reset by peer) on X server :0.
unity-window-decorator: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.

Graphics card is an ATI FirePro V3700 (FireGL)

share|improve this question
2  
I've seen this happen when the window manager crashes. Look in .xsession-errors (and possibly .xsession-errors.old) for evidence that this may have happened. Also, I'm wondering if you have applied all updates, as a fix may already exist for this problem. Finally, you can also try upgrading to Ubuntu 11.10 and seeing if the problem goes away. –  roadmr Jan 10 '12 at 20:21
    
I have observed this when closing certain fullscreen applications in Wine, but it is probably not applicable to this situation. –  Satchit Bhogle Jan 10 '12 at 21:23
1  
Yeah, also sounds like a window manager crash to me. –  tumbleweed Jan 10 '12 at 21:37
1  
Are you using the Open-Source or Proprietary ATI drivers? You can test this by searching for "Catalyst COntrol Center" in the dash. If the CCC comes up a s a result, then you are using proprietary drivers. If not, then you are using open-source drivers. –  William Jan 13 '12 at 14:04
    
Open a gnome-terminal and run (unity &) - if that causes the same behavior, then your shell crashed. In that case it would be great if you could report this as bug (instructions), running ubuntu-bug unity from a gnome-terminal. –  htorque Jan 14 '12 at 13:22

1 Answer 1

up vote 1 down vote accepted
+50

Wow, yes, it's a crash of the "unity-window-decorator". The underlying X server may be the root cause for this. This shouldn't happen. This may be best treated as a bug report to Ubuntu, for this I suggest:

  • Edit /etc/default/apport and set enabled=1
  • Reboot
  • Log in and start doing stuff
  • When the crash happens, you'll get a prompt to file a bug, follow the instructions.
  • Afterwards, disable apport (enabled=0) as it consumes extra resources.

As a way to stop this from giving you trouble, I can suggest two things:

  1. Use the "classic" environment, which doesn't use Unity or stress the graphics hardware so much.
  2. Upgrade to Ubuntu 11.10, things may be more stable, and if you keep experiencing the same problem, you can switch to Unity 2d, which is much closer to the experience you're used to.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.