Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Google Chrome 48.0 32-bit. Today when I launched Google Chrome, I got this message:

This computer will soon stop receiving Google Chrome updates because
this Linux system will no longer be supported

I thought Ubuntu 14.04 is supported for five years, what's exactly happening here?

And on 64-bit Ubuntu, I get an error from Update Manager and apt-get update:

Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release 
Unable to find expected entry 'main/binary-i386/Packages' in Release file
(Wrong sources.list entry or malformed file)  
Some index files failed to download.  
They have been ignored, or old ones used instead.  
share|improve this question
34  
Google Chrome is not provided by Ubuntu repositories. – xangua Jan 22 at 6:30
3  
@xangua Okay, but why the message? Is there a way I can disable it or maybe make my Ubuntu supported? – Parto Jan 22 at 6:38
7  
For whatever reason they claim they will no longer suport 14.04 (older dependencies? ) you'll have to find a way to directly contact and ask Google. The duplicate mentioned only says they're basically lazy... – xangua Jan 22 at 6:44
3  
@Parto "or maybe make my Ubuntu supported" Sure: convince Google to support it. – fkraiem Jan 22 at 10:52
1  
Are they doing this for the same reason they pulled the Windows Vista specific build a year ago - not enough people testing the prerelease versions to maintain adequate QA. – Dan Neely Jan 22 at 15:52
up vote 108 down vote accepted
+250

Important information on how to install Google Chrome in Ubuntu 16.04 LTS at the bottom !

This message is valid for Linux 32 bit systems only, 64 bit systems of course will stay supported. When you have the 32 bit version of Ubuntu installed, Google Chrome will not receive updates, starting from March 2016 - this already was announced by Google back on December 1st 2015.

Google: We will end support for Google Chrome on 32-bit Linux, Ubuntu Precise (12.04) ...

When you want to receive Chrome updates - you should switch to the 64 bit version of Ubuntu. Ubuntu 14.04.3 LTS and Ubuntu 15.10 are recommended to download in 64 bit flavour anyway. The next Ubuntu LTS edition 16.04 Xenial Xerus will be released in April 2016, install it in 64 bit.

In the time frame from March to April you can use the pre-installed Firefox web browser instead. Alternatively you can install chromium-browser or epiphany-browser from Ubuntu repositories. Or you can install the 64 bit version of Ubuntu 14.04, but is this worth the effort? ... you decide ...

The five year support for Ubuntu LTS editions covers the system including official repositories. Google Chrome is not available in the official Ubuntu repositories and that is the reason why there is no five year LTS support for Chrome provided from the Canonical/Ubuntu developers.

Update information 2016-03-03: Google has removed the 32 bit version from their repository !

As you can see on the Google Chrome website, there is no 32 bit Linux edition offered anymore.

Running sudo apt-get update gives the following error:

Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release 
Unable to find expected entry 'main/binary-i386/Packages' in Release file
(Wrong sources.list entry or malformed file)  
Some index files failed to download.  
They have been ignored, or old ones used instead.  

As a workaround set the repositories specifically for 64 bit:

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list" "/opt/google/chrome/cron/google-chrome"

Reference: Fix "Failed to fetch" Google Chrome repository

Update information 2016-03-09: Google seems to have fixed the issue in version 49.0.2623.87 !

/opt/google/chrome/cron/google-chrome file now has these architecture relevant entries:

# sources.list setting for google-chrome updates.
REPOCONFIG="deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main"
REPOCONFIGREGEX="deb (\[arch=[^]]*\bamd64\b[^]]*\][[:space:]]*)?https?://dl.google.com/linux/chrome/deb/ stable main"

/etc/apt/sources.list.d/google-chrome.list file shows this architecture relevant entry:

### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

Update information 2016-04-21: How to install Google Chrome browser in Ubuntu 16.04 LTS

There currently is an issue to install Google Chrome by downloading from Google website. When clicking on the .deb file Ubuntu Software opens, but nothing happens when you click on Install. Install Google Chrome properly this way - open a terminal and execute the following commands:

echo "deb http://dl.google.com/linux/chrome/deb/ stable main" | sudo tee /etc/apt/sources.list.d/google-chrome.list  
wget -q -O - https://dl.google.com/linux/linux_signing_key.pub | sudo apt-key add -  
sudo apt-get update
sudo apt-get install google-chrome-stable

There is little new "weak signature" issue when updating the repositories - but it can be ignored:

W: http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg: Signature by key 4CCA1EAF950CEE4AB83976DCA040830F7FAC5991 uses weak digest algorithm (SHA1)  
share|improve this answer
6  
what if the person is running 32 bit OS, what should he do? should mention about it – edward torvalds Jan 22 at 10:51
    
Oh, okay. I am a Firefox user though sometimes I fire up Chrome for testing purposes. I can wait till 16.04. Thanks. – Parto Jan 22 at 11:34
3  
Technically speaking one can still use Chrome on 32 bit system, it just means it won't be supported, and if there is a security hole , Google won't patch it. Best solution is maybe to switch to a 64 bit system, or chromium as an alternative – Serg Jan 22 at 16:08
5  
I am on 64 bit Ubuntu 12.04 and about:chrome says its 64 bit, but sill getting same message. Version 48.0.2564.82 (64-bit) – user871199 Jan 22 at 19:01
4  
@LightnessRacesinOrbit I've already migrated to Firefox due to Google's way of shoving us the profile button. Now they disown Ubuntu 32bit users. ETA until Google discontinues Chrome because no-one's using it anymore? – Jan Dvorak Jan 23 at 3:06

What's happening is that the word "supported" in this message does not mean what you think it means. When Google says "this system will no longer be supported", what they say is "we will stop providing Chrome update for this system". On the other hand, when Canonical says "Ubuntu 14.04 will be supported for five years", what they say is "packages in the official repositories will receive upgrades for five years". Because the Chrome packages are not in the official Ubuntu repositories, there is no contradiction between the two.

share|improve this answer
3  
It's a fact of life about legacy systems (I know I've nursed more than a few along over the years). Support costs (money or time, it doesn't really matter how you account it). Software providers have to decide where to put their resources and eventually they will cut off older lines. In this case the OP felt confident because he thought he had a guarantee, but then he added a software component outside that guarantee. – dmckee Jan 23 at 18:28

EDIT: It appears as though Google has added the correct changes to the updates. So, simply fixing the repository line, then running the update should be good from now on.


Google stopped 32bit Chrome support for Linux. Interestingly enough, on Google Chrome download site, they still have the link to the 32bit version.


To fix it, make the following changes:

(Optional) First, remove Google Chrome and the repository file: Don't worry, your settings should still be safe.

sudo apt-get remove google-chrome-stable
sudo rm /etc/apt/sources.list.d/google-chrome.list*

Then update the system:

sudo apt-get update

Next, fix the Google Chrome repository file following commands:

Add the key: Only if this is a first time installation.

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

Then add the changes to the repository:

sudo sh -c 'echo "deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main" > /etc/apt/sources.list.d/google-chrome.list'

If Google Chrome is already installed:

sudo apt-get update
sudo apt-get upgrade

If it is not installed:

sudo apt-get update
sudo apt-get install google-chrome-stable

Hope this helps!

share|improve this answer
    
@JoeMorano You're welcome! =) – Terrance Mar 6 at 4:07
    
The problem is that this setting will be reverted after the first Chrome update. – Pilot6 Mar 9 at 10:16
    
@Pilot6 Good point. I modified my answer here, that as of this morning with a Chrome update, it did not modify my changes. – Terrance Mar 9 at 14:41
    
I fixed the update problem by just adding the [arch=amd64] to the repository definition. update completed successfully afterwards. No uninstall/install needed – uval Mar 9 at 14:59
    
@uval You know, I am honestly thinking that it is the way that people originally install Google Chrome that makes the difference. If you install from the web, which downloads the .deb file, it puts in those settings automatically that can change it later. I did that the first time, and an update changed mine. After doing it this way in the answer, it has not changed it since. Just a thought. – Terrance Mar 9 at 15:07

Switch to Chromium - it is virtually identical (it even lets you log into Google the same as Chrome), fully open source, and provided by Ubuntu repositories.

For Flash support with Chromium, follow these instructions.

share|improve this answer
4  
@fig "several" is an exaggeration. Chromium on 14.04 and above is at 47.0.2526.106-0ubuntu0.14.04.1.1107, Google Chrome is at 48.0.2564.82-1 ... which came out about two days ago. – muru Jan 22 at 10:33
14  
This could have been a good comment, but a poor answer as it does not even attempts to make an answer. – meskobalazs Jan 22 at 10:51
2  
@fig flash? are people still using that thing? – njzk2 Jan 22 at 15:35
5  
Cannot watch netflix in Chromium which is the only reason I have Chrome on my old netbook :( – Organic Marble Jan 22 at 22:16
2  
@meskobalazs not yet, it takes 50. It only lets me comment here because it's my post – Keith Jan 23 at 8:29

Please read https://groups.google.com/a/chromium.org/forum/#!topic/chromium-dev/FoE6sL-p6oU

From there:

To provide the best experience for the most-used Linux versions, we will end support for Google Chrome on 32-bit Linux, Ubuntu Precise (12.04), and Debian 7 (wheezy) in early March, 2016. Chrome will continue to function on these platforms but will no longer receive updates and security fixes.

We intend to continue supporting the 32-bit build configurations on Linux to support building Chromium. If you are using Precise, we’d recommend that you to upgrade to Trusty.

share|improve this answer
2  
Is 64-bit Linux really the "most-used Linux" by a big margin? I doubt it. – Lightness Races in Orbit Jan 23 at 2:12
    
I like how Google say "upgrade" when they mean "do something to let us force you to use our stuff". – wizzwizz4 Jan 23 at 10:19
4  
Why would anyone still be using 32-bit Unix? 64-bit CPUs have been common for almost a decade. – Alan Shutko Jan 23 at 19:44
1  
@LightnessRacesinOrbit : according to latest Steam survey, store.steampowered.com/hwsurvey , the top 5 Linux distros, that alone correspond to ~60% of all their Linux users, are 64-bit. – MestreLion Jan 23 at 20:53
3  
@AlanShutko Because we have old hardware. – Organic Marble Jan 24 at 13:50

On Ubuntu 64-bit, type the following commands:

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list"

And

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/opt/google/chrome/cron/google-chrome"

Update package: sudo apt-get update

According to webupd8 On 64 bit OS you need to edit the following two files:

/etc/apt/sources.list.d/google-chrome.list

Change line #3 from:

deb http://dl.google.com/linux/chrome/deb/ stable main

to:

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

Edit /opt/google/chrome/cron/google-chrome

Change REPOCONFIG and SSLREPOCONFIG from:

REPOCONFIG="deb http://dl.google.com/linux/chrome/deb/ stable main"
SSLREPOCONFIG="deb https://dl.google.com/linux/chrome/deb/ stable main"

To

REPOCONFIG="deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main"
SSLREPOCONFIG="deb [arch=amd64] https://dl.google.com/linux/chrome/deb/ stable main"
share|improve this answer

According to http://www.webupd8.org/2016/03/fix-failed-to-fetch-google-chrome_3.html, do the following from the command prompt:

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list"

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/opt/google/chrome/cron/google-chrome"

Note that per the source above, "this file is changed on each Google Chrome update and it looks like there's no way around that (changing /opt/google/chrome/cron/google-chrome or /etc/default/google-chrome doesn't affect this) so until Google changes this in its package, you'll need to apply the fix above after every Google Chrome update.... A workaround would be to make the .list file immutable, so it can't be changed by any Google Chrome updates, by using "sudo chattr +i /etc/apt/sources.list.d/google-chrome.list" (which can be reversed using: "sudo chattr -i /etc/apt/sources.list.d/google-chrome.list") but this is not ideal and you should change this file back once Google fixes this on their end."

share|improve this answer

protected by Community Feb 23 at 19:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.