Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a frequent user of the USA Dvorak keyboard layout, but have the default QWERTY keyboard. Stuff works simply by adding the layout in the Keyboard settings in Ubuntu, and worked well in 11.04.

However, upon upgrading to 11.10, while I'm able to use Dvorak in normal session I'm stuck with QWERTY in Lock Screen. My Dvorak layout doesn't exist in lock screens. I even added a custom shortcut to initiate it, but no luck.

Any ideas and workarounds?

share|improve this question
add comment

1 Answer

If you only have 1 keyboard layout, try adding a Qwerty english one too. That way when it locks you'll be shown the available keyboards, and you can simply change to the one of your choice.

Hope I helped.

share|improve this answer
    
Just a note, but it makes sense that it might work differently in 11.10 than in 11.04. 11.10 uses gnome-screensaver, which is still not complete and the reason you still don't have a screensaver when it locks. I think 11.04 used xscreensaver but I could be wrong. –  Theo Scholiadis Oct 26 '11 at 14:17
    
I don't mind the screensaver; my primary concern is the Keyboard Layout. Also, I have both QWERTY and Dvorak with a Ctrl+Shift shortcut to switch between them. When it locks, the "blank" lock screen shows the available keyboards, but both keyboards are QWERTY, while the Login Screen shows no options. I'll take a look. –  Tushant M Oct 26 '11 at 17:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.