Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was trying to get multitouch working on my 11.10 installation. Some googling led me to believe that I should install:


to do that. This seems to be incorrect and may have messed up my system.

Ever since I installed this, not only does my install still not have multi-touch, but my touch pad occasionally does not work, I have some booting freezes, and am asked to partial upgrade. (Apparently fiddling with xserver is some kind of partial upgrade, I take it?)

Anyway, before partial upgrading, I saw that this package would be uninstalled, but no new xserver-xorg-input would be installed to replace it. (However, 172 other packages will be added, including CUPS, Empathy, and gedit, which all seem to currently work fine.)

Given that it may be removing something important in xserver-xorg, and that it may be installing new(?) versions of things that already were upgraded for 11.10 and working fine (and as far as I know, /not/ removed), is it safe to do this partial upgrade or not?

(Sidenote, I've consulted Upgrade manager wants me to do a partial upgrade and Partial Upgrade and I think my case is a little different, because these cases seemed to genuinely start an upgrade and finish part-way through it, whereas I just installed an inappropriate version of something, and want to get back to the right one.)


share|improve this question
Alright, no screams of alarm? I'm going to do it. Fingers crossed. – Mittenchops Oct 27 '11 at 7:21
Turns out that not only had I installed multitouch and mutouch drivers, but I had somewhere in there also added ppas for xorg-edgers and maybe others. These are where the trouble started. – Mittenchops Oct 28 '11 at 13:22
up vote 1 down vote accepted

For anyone else's benefit in a similar position: briefly, this was a mess. I had apparently blindly installed some bleeding edge repositories to update my xorg for the sake of a multitouch screen, so the partial upgrade took me into the future. And the future was a terrifying place where things didn't work.

I eventually discovered I needed to roll back xorg and xserver-xorg, by comparing my installation with a brand new ubuntu install thanks to some advice from this post.

However, since then, I still have some issues cropping up, such as an inability to take screenshots, and being unable to connect to wifi at boot without first connecting to eth0 (haven't confirmed, but I suspect it's the same lib).

I have traced these errors to xorg and also having a scary future version of libglib2 installed, namely 2.31.0 instead of 2.30.0. That has not yet been solved, but has been posted as its own question here.

The short answer I will say, then, in response to this question is: NO, DO NOT PARTIAL UPGRADE! And more importantly, if you're seeking multi-touch, watch which repositories you install to get it---don't just follow forums. There is a known bug with xorg-edgers that pushes you down to unity-2d, and in my experience, that caused major dependency problems I have yet to resolve.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.