Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently installed Steam via PlayOnLinux, but every time I want to run it, it gives me a screen with:

"Fatal error: could not load module 'bin/FileSystem_Steam.dll' "

There is nothing about this error on the internet. Could anyone please help?

share|improve this question
add comment

2 Answers

Install wine 1.3 - the latest development version using the Wine PPA.

Then follow the HOWTO found here Wine App DB Steam

share|improve this answer
    
I've already tried that method, but it gives me the same error. –  Hotknife Oct 26 '11 at 12:03
1  
have you tried delete/moving the ~/.wine directory and installing from scratch? A bit of googling suggested re installing steam –  Anarci Oct 26 '11 at 12:13
    
Just tried that, no succes :( Quite weird that this isn't a common problem... I can't find anything about it on the internet. –  Hotknife Oct 26 '11 at 12:29
    
@Hotknife Its most likely a wine regression in the wine development version. If you have the know how you can try doing a git bisect to identify the problem Regression Testing. Althought this is a lot of effort. Does wine 1.2 produce the same error? –  Anarci Oct 26 '11 at 13:00
    
I found some time to test your method, and now it works :D Thanks mate! –  Hotknife Dec 4 '11 at 10:26
add comment

I've tried to install Steam via Playonlinux, and i've had success.

First, try to install the latest version of Playonlinux from the official website, because the one in the Software Center a little bit old version.

After downloading the .deb package, the Software Center will update the installed Playonlinux.

Then try to uninstall/reinstall steam.

On my computer the install went fine, Steam update and login successful, but I didn't try any games at all.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.