Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

II.04 was working perfectly on my Acer Aspire 3050 laptop, until I upgraded a couple of days ago. Yesterday, I was unable to type in my password as only about half the keys on kb are working. I logged in on a guest account, but couldn't do anything or access Internet because I needed to type in my pw to do so.

Decided to do a fresh install of 11.04. however I can't enter BIOS using the designated key (F2) to make it boot from CD. Guessing that it's one of the non-functioning keys. :(

Can anybody help out here? Thank you in advance.

share|improve this question
add comment

2 Answers

If your keyboard doesn't work while loading the BIOS (that loads before Ubuntu and is OS independent), it's not an Ubuntu problem, not related to any update. I can't think of any way in which a OS can change how the BIOS manages keyboard. Installing another OS (Ubuntu 11.04 or Windows) is not going to solve this.

The most likely cause is some hardware related problem. You can try to attach an USB keyboard to the computer and enter the BIOS from it.

If you don't fear screwdrivers and the laptop is not under warranty you should check the connection of the keyboard to the main-board. Otherwise is time to get it to a computer repair shop.

share|improve this answer
add comment

I just upgraded to 11.10. The problem is I can't use keyboard to the user which I always use. The keyboard works fine when login. It also works fine in guest session. And I tried to make another user account and the keyboard also worked fine. I don't know what's the problem.

Can anybody help out here? Thank you

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.