Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had purchased an HP Pavilion with the unsupported graphics card Radeon HD 6470M. I chose to not install the ATI proprietary drivers and simply work with the generic ones.

After my upgrade to 11.10 I noticed that after installing the ATI drivers (not the post-release ones, as apparently people have been having issues with Unity), my graphics card is working well. However, the Unity plugin was unchecked in Compiz. I have rechecked it but nothing has changed. No matter what I check or uncheck in compiz (like wobbly windows), there is no visual effect (these effects all worked with the generic drivers). Even my desktops are in the a straight line format and not in the 2x2 orientation, which gives problems when I press Super+S.

Is there something I need to do to activate Unity again? Should I reset it? Any other advice will be appreciated.

share|improve this question
1  
try log out and in after checking unity. Else try unity --replace if does not work try unity --reset –  Stefano Mtangoo Oct 26 '11 at 9:09
    
I tried the logout and still nothing. Before trying unity --replace and unity --reset, could I know what effect it will have? I've seen that unity --reset resets everything unity related. I'm not sure, however, if the issue I have is unity related. –  Theo Scholiadis Oct 26 '11 at 9:20
    
unity --replace reloads unity with no changes in layouts but --resets resets the settings and launcher stuffs –  Stefano Mtangoo Oct 26 '11 at 9:49
1  
if all fails, try to purge and reinstall sudo apt-get purge unity && sudo apt-get install unity –  Stefano Mtangoo Oct 26 '11 at 10:29
1  
Just do not log off before you reinstall unity. Laternative will be installing Gnome shell if anything bad happen you will have backup! –  Stefano Mtangoo Oct 26 '11 at 10:42

1 Answer 1

You may be running Unity 2D - I would log out and click on the cog next to your password entry box, ensure you select Ubuntu as your desktop that way when you log in you will use Unity Shell if it has been enabled previously in CCSM.

It's a simple way to check before you try to purge then reinstall Unity......

share|improve this answer
    
I just checked and I have been running Ubuntu (not Unity 2D). Before I do a purge, should I have the option checked in Compiz? And will the reinstall put everything as it should? Will it affect the graphics card? (Sorry, I usually stick to defaults to avoid issues like this... –  Theo Scholiadis Oct 26 '11 at 11:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.