Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am not sure if this question is related to 11.10 or gnome 3.2, but the VPN configuration screen has changed, and now the user and password is optional, but there is no way for me to override it.

On our VPN we use a token, so I have to enter the password each time.

But even if I clear the password, clear the password and the user, there is no way for me to unset the user and password, so I am unable to access the VPN. Because he never asks the password anymore, and each time I return to the VPN configuration window, I see the same setting.

Please help. Is there another way to configure the VPN?

share|improve this question
up vote 1 down vote accepted

If add a new VPN connection, it will work once. But every time I connect it will automatically save the previous password.

Previously (when I posted this question), I was unable to set the password back to nothing. Now that does work.

So to connect to my VPN I have to

  • open my VPN configuration, set the password to blank and save the configuration
  • only then can I logon succesfully.

I noticed there was a bug reported for exactly this case:

[UPDATE] On the bug-report, a work-around was posted. Setup the flag "password-flags=2" under [vpn] section in the related VPN config file, located here in Ubuntu:

/etc/NetworkManager/system-connections/<name of your vpn connection>

and under the vpn-section:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.