Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

After tearing down my laptop, I came to know that most of the heating issue in my laptop is caused by HDD. Powertop is also showing the same problem. I am seeing significantly cooling after activating the power saving mode using the powertop but it is not permanent. In next reboot it will again reset.

>Powertop output:
Bad           Enable SATA link power management for /dev/sda

I have already activated the laptop-mode tool and set all the HDD power option in laptop-mode.conf file, but non of them resolving my problem.

How can I make the powertop suggestion permanent?

share|improve this question

marked as duplicate by Mitch, AgentCool, Jorge Castro, Uri Herrera, Eric Carvalho May 20 '13 at 2:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

Have a look at this: TLP

Among other stuff, theres this option in the config file:

# SATA aggressive link power management (ALPM):
# min_power/medium_power/max_performance
SATA_LINKPWR_ON_AC=max_performance
SATA_LINKPWR_ON_BAT=min_power

I find TLP quite useful, as it combines several PM utils and options in one package.

Additionally you might want to re-enable PCIE_ASPM in your kernel (the famous kernel PM regression) -

share|improve this answer
    
Thanks Marto.. You saved my day... laptop-mode is just a crap. TLP is gold in power management. I am able to configure my HDD and sound power using that tool. –  Abhijeet Oct 26 '11 at 10:05
    
you're welcome! –  marto Oct 26 '11 at 13:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.