Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to 11.10, grub doesn't load on every other boot (all the odd number boots, for example). It just sits at a purple screen and waits for me to reboot the computer to load grub again. Any idea what this is or how to fix it? I haven't had much luck Googling for it.

I checked dmesg and /var/log but found nothing suspicious. Wouldn't dmesg be from the resulting successful boot and not from the previous failed boot?

share|improve this question
    
The problem is not GRUB, the bootloader. The logo shown is Plymouth, the bootsplash. Something freezes. Check your dmesg and other logs. Log files are stored in /var/log/. –  Anonymous Oct 26 '11 at 6:56
    
Thanks. I'll take a look. I was trying to debug ACPI and now it wont boot so it may take a bit :) –  Luke Hoersten Oct 27 '11 at 1:23
    
I checked dmesg and /var/log (not sure which file you specifically intended there) but found nothing suspicious. Wouldn't dmesg be from the resulting successful boot and not from the previous failed boot? –  Luke Hoersten Oct 27 '11 at 2:05
add comment

closed as too localized by Luis Alvarado Mar 14 '13 at 17:25

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.