Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installed Ubuntu 11.10 64bit today and got to a problem. Can't connect to Windows 7 shared folders.

I have tried every single method I could find on google. Mount with "mount cifs", "smbmount", changed homegroups, etc and no luck.

Windows 7 is clean setup with no-password sharing enabled. Other windows computers can access shares without a problem.

On ubuntu I can see windows 7 under WindowsNetworks->WORKGROUP> but nothing.

Edit: It looks like now I can see shares of other windows 7 computer (with login and password) but not the one I need (without login and password)

share|improve this question
1  
I might be wrong, but I think the "simple" Windows Homegroup Shares dont work, you have to share folders the 'old' way (right click on folder, properties, sharing or similar) –  marto Oct 26 '11 at 8:03
    
I tried every possible way of sharing from win7. Hell I can see win xp shares but not win7. Microsoft did something nasty there. Installing linux for storage :| –  jM2.me Oct 28 '11 at 1:19
    
are you using any special characters in the user passwords? like #? –  marto Oct 28 '11 at 18:04
    
homegroup share will not work since remember you actually have to enter the password for homegroup joining, which is managed by win 7. and ubuntu has no idea about that! –  Vineet Menon Nov 8 '11 at 7:21
add comment

2 Answers

up vote 1 down vote accepted

I ran into this problem after upgrading from Ubuntu 10.x. installing smbfs with

sudo apt-get install smbfs

fixed it. I was connecting to a network drive, though, not a window$ box.

Good luck

share|improve this answer
add comment

I found that I could not find windows shares under Browse Network, but could under /mnt/hgfs (which you can navigate to in Nautilus).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.