Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on Ubuntu 11.10 and I have installed Gnome shell extensions.

For the weather extension the problem is that it is only showing the temperature that it showed when installed for the first time. That means while the current temperature is 25 it is continuing to show it as 32.

I have entered the correct WOEID.

Need your help to solve this issue.

share|improve this question

5 Answers 5

This is what i did:

  1. go to http://weather.yahoo.com and enter your location
  2. klick on "RSS" (on the right side)
  3. your location code is shown in the address-bar (eg. weather.yahooapis.com/forecastrss?p=GMXX0087&u=f)
  4. copy your code (GMXX0087 in my case) and open a terminal
  5. set location and city with

    gsettings set org.gnome.shell.extensions.weather woeid "'GMXX00187'"

    gsettings set org.gnome.shell.extensions.weather city YOURCITY

  6. logout & login again

share|improve this answer
    
Thanks for the steps. Actually I did all the steps earlier and tried them again now. But for some reason my temp still shows "Haze 34 C" while it is actually Haze 28 C (I logged out and then logged in). The city for which I am trying to the get the temp is "Kolkata, India" WOEID is "INXX0028" –  Arindom Oct 27 '11 at 13:22
    
As soon as I put those commands into terminal (with my details) the extension worked, did not even have to log out. Thanks –  Victor9098 Dec 1 '11 at 18:42
    
Thanks. Although it's weird the "new" applet does not have the ability to enter your location directly, whereas the "old" one did. –  Cerin Mar 15 '12 at 13:49

Hmm, after I used the 3 letter code additional to my WOEID code it was successful.

share|improve this answer
1  
I have only mentioned the six character code of my city. That means I need to add three more letters code to it? Can you please specify more about three letter code and how to get it? –  Arindom Oct 27 '11 at 4:51
    
City: "FRA" (Frankfurt, Germany) WOEID: "GMXX0040" (changed to this after given the correct WOEID; I don't know your city) –  brubaker Oct 27 '11 at 11:19
    
I am trying for city "Kolkata, India", for which the WOEID is "INXX0028". –  Arindom Oct 27 '11 at 13:20

Alternative:

http://www.omgubuntu.co.uk/2011/10/my-weather-indicator-adds-geolocation-support/?utm_source=feedburner&utm_medium=twitter&utm_campaign=Feed%3A+d0od+%28OMG%21+Ubuntu%21%29

A new ‘My Weather Indicator’ Adds Geolocation Support

share|improve this answer
    
Thanks for the link but will that work for gnome-shell (Sorry that I didn't mention specifically) ? I think it is meant for Unity. –  Arindom Oct 27 '11 at 13:18

http://xoap.weather.com/search/search?where=Guangzhou

That website is where I solved my problem. Change 'Guangzhou' to your city instead, and the id is what you want.

share|improve this answer
    
This does not provide a sufficient answer to the question. Try to add more information, and / or examples. –  Mitch Oct 7 '12 at 10:24

The above suggestions did not work for me, so I figured out the following steps, which got me the exact weather for my location. Sorry, I would post more links but the forum does not allow me to post more than 2 links.

  1. Go to the Yahoo weather page.

  2. Then, search for your city. In the URL, you will see a unique numerical ID for your location. For example, Kansas City's ID is 2430683.

  3. Copy that numerical ID and put it at the end of this link: http://weather.yahooapis.com/forecastrss?w=. This is the link for the RSS feed. For example, for Kansas City the RSS link would be http://weather.yahooapis.com/forecastrss?w=2430683

  4. Towards the bottom of the RSS feed page, you will see a hyperlink that reads "Full Forecast at Yahoo! Weather". Click that link. It will open the Yahoo weather page for your location again, however the URL will be different. The URL now should contain the WOEID that has both letters and numbers. For example, the Kansas City WOEID is USMO0460.

5) To update your WOEID, you can follow the terminal instructions in the first answer above and type in your terminal:

gsettings set org.gnome.shell.extensions.weather woeid "'GMXX00187'"
gsettings set org.gnome.shell.extensions.weather city YOURCITY

Then log out and log in.

Alternatively: You can click the weather app button and click on the upper right settings button. Then type in the WOEID and Override Location Label.

share|improve this answer
    
"The above suggestions" is really relative, since answers are always sorted by their voted score. So the order might change in the future. –  MadMike Nov 25 '13 at 6:56
    
I've changed your answer make easier to read. You can always change it back if you don't approve. –  MadMike Nov 25 '13 at 7:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.