Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a USB sound device that used to work back when I ran other versions of Ubuntu. Now I can only partially see the device. I have tried many things I saw in Google searches, but none solve my problem.

cat /proc/asound/cards sees the device as card 0

  • aplay -l shows C-Media USB Audio as card 0
  • alsamixer sees the device
  • asoundconf list does not show the device
  • sound preferences shows no hardware
  • asoundconf-gtk set the device to pulseaudio, but fails with python errors ending in ValueError: too many values to unpack in the function set_default_card. I think this is the cause of my problem.

The device is a Sony virtual phones wireless headphone amplifier.

share|improve this question
    
Is the device visible in the Sound Preferences in the GUI? –  JanC Oct 14 '10 at 17:03
    
no, there are no devices listed –  David E. Anderson Oct 14 '10 at 22:44
    
Does it show in pavucontrol? –  maco Oct 14 '10 at 23:43
    
no, it does not show in pavucontrol. I see only Dummy Output –  David E. Anderson Oct 15 '10 at 1:46
    
I'd file a bug. ubuntu-bug -s audio –  maco Oct 15 '10 at 19:47
show 6 more comments

4 Answers 4

Bug report here

share|improve this answer
add comment

I had a similar problem. I found a bug in the asoundconf script. (It did not allow comments in some configuration file(s) after a parameter-value-set.) You can find a fixed version at http://www.tu-harburg.de/~sedt1131/asoundconf which solved the problem for me. (I have not found a proper way to report the bug, so I started by uploading the fixed version to my webspace...)

share|improve this answer
add comment

I disabled the onboard sound and USB worked. I sometimes have to

'alsa restart' to get it to work.

share|improve this answer
add comment

I had this issue today and entering pulseaudio -k in the terminal did not fix it completely, as I also needed to end whatever audio mixer was associated with my desktop environment; for KDE, for example, you enter in the terminal

killall kmix
pulseaudio -k
kmix

and then your USB sound device should be detected.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.