Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.10 on the Acer S3 ultrabook and I am trying to get the touchpad to work with two button scrolling. When I go to System Settings -> Mouse and Touchpad I don't see any touchpad preferences there, only basic mouse settings.

When I run xinput I get the following:

 Virtual core pointer                           id=2    [master pointer  (3)]
    Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
    PS/2 Elantech Touchpad                      id=11   [slave  pointer  (2)]

Does anyone know how to get the touchpad working ?

share|improve this question

3 Answers 3

First off does the touch-pad support two finger scrolling? If so the result of synclient -l would be nice to edit

add the output of the command synclient -l.

Parameter settings:
    LeftEdge                = 1775
    RightEdge               = 5503
    TopEdge                 = 1652
    BottomEdge              = 4662
    FingerLow               = 24
    FingerHigh              = 29
    FingerPress             = 255
    MaxTapTime              = 180
    MaxTapMove              = 245
    MaxDoubleTapTime        = 180
    SingleTapTimeout        = 180
    ClickTime               = 100
    FastTaps                = 0
    EmulateMidButtonTime    = 75
    EmulateTwoFingerMinZ    = 10
    EmulateTwoFingerMinW    = 6
    VertScrollDelta         = 111
    HorizScrollDelta        = 111
    VertEdgeScroll          = 0
    HorizEdgeScroll         = 0
    CornerCoasting          = 0
    VertTwoFingerScroll     = 1
    HorizTwoFingerScroll    = 0
    MinSpeed                = 1
    MaxSpeed                = 1.75
    AccelFactor             = 0.0359131
    TrackstickSpeed         = 40
    EdgeMotionMinZ          = 29
    EdgeMotionMaxZ          = 159
    EdgeMotionMinSpeed      = 1
    EdgeMotionMaxSpeed      = 445
    EdgeMotionUseAlways     = 0
    TouchpadOff             = 0
    LockedDrags             = 0
    LockedDragTimeout       = 5000
    RTCornerButton          = 2
    RBCornerButton          = 3
    LTCornerButton          = 0
    LBCornerButton          = 0
    TapButton1              = 1
    TapButton2              = 3
    TapButton3              = 2
    ClickFinger1            = 1
    ClickFinger2            = 1
    ClickFinger3            = 1
    CircularScrolling       = 0
    CircScrollDelta         = 0.1
    CircScrollTrigger       = 0
    CircularPad             = 0
    PalmDetect              = 0
    PalmMinWidth            = 9
    PalmMinZ                = 199
    CoastingSpeed           = 20
    CoastingFriction        = 50
    PressureMotionMinZ      = 29
    PressureMotionMaxZ      = 159
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    ResolutionDetect        = 1
    GrabEventDevice         = 1
    TapAndDragGesture       = 1
    AreaLeftEdge            = 0
    AreaRightEdge           = 0
    AreaTopEdge             = 0
    AreaBottomEdge          = 0

You can change the setting of the synclient by adding to the startup application a new application with the following command:

xterm -e synclient "EmulateTwoFingerMinZ=10"

This would change the setting of EmulateTwoFingerMinZ to the value of 10

Found similar answer here: How to get two-finger scolling to work?

share|improve this answer
    
I think the OP is long gone and I appreciate your answer. –  bodhi.zazen Mar 8 '12 at 0:35
    
thank you very much sir –  Ringtail Mar 8 '12 at 0:47

1)Click the top-right icon of your desktop and select "System Settings"

2)Click the "Mouse and Trackpad" icon

3)Go to "Touchpad" tab, check the "Two-finger scrolling" option and check "Enable horizontal scrolling"

Now you must have two finger scrolling.. :)

share|improve this answer
    
The OP indicated "When I go to System Settings -> Mouse and Touchpad I don't see any touchpad preferences there, only basic mouse settings". –  bodhi.zazen Mar 4 '12 at 5:20

Install ubuntu tweak (latest version from repository). Then click on Tweaks->miscellaneous->natural scrolling

share|improve this answer

protected by Community Nov 11 '11 at 14:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.