Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 11.10 i386 32-bit on ma iMac (21", c2d 2.66, 4GB Ram) but I have a problem that I can't solve out: the audio is not working, after a lot of struggles with alsa, i found out that, at the back of the pc, there is the red light coming out from the headphones socket. (macs have the output thing that works as analog if you put an analog jack, and as digital if you put an optical (longer) special jack inside. Ubuntu sends out a digital output instead of sending sound to the iternal speakers. Codec: Realtek ALC889A

Help me!

share|improve this question
    
AFAIR, iMacs have the optical output turned on no matter if the OS uses it or not. Have you tried help.ubuntu.com/community/Intel_iMac#Sound ? –  Dominik Oct 26 '11 at 0:18
add comment

2 Answers

open a terminal window and give:

amixer set IEC958 off

share|improve this answer
add comment

Have you tried clicking the sound icon in the dash, going to sound settings, clicking the hardware tab, selecting the internal audio device and selecting Analog Stereo Output? Also, I have found that sometimes when you change the profile there is no audio (like it's muted) even though everything is set correctly. To fix this, go through all the profiles looking for one that's muted and un-mute it. I have the same audio chipset as you and couldn't get sound on digital out until I went back into Analog Stereo (which had been muted, not by me), un-muted it and changed back to Digital Stereo.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.