Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Help please. Put it on the computer ubuntu 11.10 64bit. Used the response in the topic WiFi does not work, Broadcom STA Wireless driver does not work on a BCM4313 but this does not help. Computer Lenovo z570, wifi card Broadcom Corporation BCM4313

When choosing Network Manager > Enable Wireless nothing happens. WiFi not enabling.

share|improve this question
1  
Similar question here - does the answer work for you? askubuntu.com/questions/66674/… –  fossfreedom Oct 25 '11 at 19:33
add comment

4 Answers 4

I had a similar problem today on ubuntu 11.10 64-bit, but my platform is an acer 4755g.

1st of all, let's be absolutely sure that your z570 is using a broadcom http://consumersupport.lenovo.com/uk/en/DriversDownloads/drivers_list.aspx?CategoryID=307140

as you can see, z570 supports 1. intel (several diff types) 2. broadcom 3. Atheros

You do this by 1. opening a terminal 2. running the command

alvinh@ibmsda6:~$ lspci | egrep -i "Atheros|broadcom|intel"

This is my other pc which also run ubuntu 11.10, but the i386 version 02:02.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)

In your question, you were very specific that you have a BCM4313, so i'm gonna take yr word for it. Let's assume that you've done a lspci & it returns "wireless" & "broadcom" on the same line since this is the only hardware that supports 64bit.

  1. Now install this package http://packages.ubuntu.com/oneiric/b43-fwcutter

sudo apt-get install b43-fwcutter

  1. when that's done, goto System Settings (should be on the launcher on the left) Hardware/Additional Drivers -> Broadcom <- Enable this driver

  2. The rest is the same as previous releases of ubuntu; on the top right-hand, click on the LAN & configure your wireless lan info.

Good luck Alex; this is as best as i can do for you bec it's exactly what i did!

share|improve this answer
add comment

This is what helped me:

The Broadcom STA driver under System Settings should be installed. Check if acer-wireless is blocked via

rfkill list all

If it is blocked then edit your blacklist.conf and add following:

blacklist acer_wmi

Then restart and all should work fine. It's strange, but it works without problems.

Related
Can't enable wireless on an Intel WifiLink 1000 on an Lenovo Ideapad z570

share|improve this answer
add comment

For those who don't have Internet running on the Ubuntu machine/boot. Download the b43 driver from the above link and then use the following command to install it.

sudo dpkg -i b43-fwcutter_014-9_i386.deb

Replace the filename with the one's you have downloaded move to the folder you have downloaded the file.

Now reboot, hopefully the WiFi is working now.

share|improve this answer
add comment

Please have a look to my answer on the following question

How do I get the Broadcom BCM4313 wireless working on an Asus 1015PX?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.