Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated to 11.10 and Urban Terror now seems very laggy in fullscreen mode when I'm using Unity 3D (Sync to VBlank is disabled). In Unity 2D I get good performance, but when I was using 11.04 I had great performance on Unity 3D as well.

Why has this changed on 11.10? I like Unity 3D more and I don't want to log out and switch to 2D just to get good performance on games. My graphics card is an HD 4250 and I have the drivers installed.

share|improve this question

3 Answers 3

A lot has changed since 11.04 and compiz is more integrated in to 11.10. Some of the options that where true to 11.04 are not an option anymore in 11.10.

If you really want to play games in linux my recommendation is an always will be, until nvidia/ATI release good stable drivers: run no effects desktop if you are playing games.

Just imagine the amount of milliseconds that you safe (and thus prevent that head shot cause you spotted the sniper on time) without having your computer calculate how pretty that 3d effect on those buttons might look like?

Short possible answer will be: Dont use 3d desktop for games, specially in 11.10, its so much heavy on graphics.

share|improve this answer

In CompizConfig Settings Manager, under Composite, enable Unredirect Fullscreen Window.

share|improve this answer

Perhaps Compiz used to unredirect fullscreen windows in 11.04, and no longer does so in 11.10?

Install ComizConfig Settings Manager, launch it, find the Composite plugin and try enabling "Unredirect Fullscreen Windows".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.