Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get a second gen ipod shuffle to work with Ubuntu 10.10. As far as i understand Rhythymbox should support this. When I plug the ipod in it shows up under the devices section of the menu, but after that I am unable to do anything with it.

I can't see the songs that are already on it, I can't add new songs, I can't do anything. When i attempt to drag a song across, absolutely nothing happens. if i try the sync with library option, it shuts rhythymbox down completely. Any ideas would be greatly appreciated.

share|improve this question
I couldn't get rhythmbox or banshee to work with my 2nd gen Shuffle but gtkpod works perfectly without issue. – user10228 Feb 4 '11 at 15:02
up vote 1 down vote accepted

In fact, I got into many troubles when I tried to force rhythmbox to work with iPods (many different generations). Eventually, I got into conclusion that rhythmbox is simply unable to work with them properly. I tried out some ipod-dedicated software, but most turned out to be an useless junk... but there is one, I can recommend you: it's Floola It gives you a simple but powerful access to your iPod, I appreciate the fact it was the only application that managed to communicate properly with my iPod without issues.

share|improve this answer

You could try this, but it should not be needed.

share|improve this answer

Im having problems similar to this. Seems rhythmbox, and possible Ubuntu itself is buggy with ipods. Here's a link to the forum with others having a similar problem with other ipods.

share|improve this answer
This entry seems to be a comment rather than an answer. – marenostrum Oct 21 '10 at 18:05

I think you will find its actually the libraries they all use that are broken (and its fairly well documented) which is why no applications using the libgpod do not work. Been like that for a year now, im still stuck on old music :/

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.