Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I disable a shortcut (Ctrl + LMB) in Ubuntu 11.10 without the compiz-manager? The compiz-manager destroys my desktop therefore I cannot use it. Is there a config file where I can disable this shortcut instead?

share|improve this question
    
are you absolutely sure you are running Unity 3D or are you running Unity 2D - obviously if you are using 2D you are not using compiz and the answer will be different? askubuntu.com/questions/62001/am-i-using-unity-or-unity-2d –  fossfreedom Oct 28 '11 at 22:02

5 Answers 5

up vote 1 down vote accepted

I now found out the solution. You have to change they keys from Alt to Super. The command is as follows:

gconftool-2 --set --type string /apps/metacity/general/mouse_button_modifier '<Super>'

It works for me.

I found the solution from the question can I disable the Alt + Windows + Right Click behaviour for editing panels in Gnome Classic.

share|improve this answer

It would appear that if the Move plugin itself is enabled it's going to want something valid for that key, if you disable the key it comes back.

So maybe try something not being used elsewhere that will 'stick'

Possibly

<Control><Alt>Button1

You should be able to use ccsm in 11.10 without much issue, there are just a few things to stay away from, editing the Move plugin wouldn't be one of them

Changes to compiz plugins from gconf-editor sometimes require a log out/in to realize (or restart compix

share|improve this answer

I would answer your question but in a slightly different way than you, probably, expect. I think in Ubuntu 11.10 you should fight the CompizConfig once and then not be afraid to use it anymore...

It indeed destroys your desktop the first time you run it when you select some of its options (for example, you select Preferences -- after that it runs for couple minutes and destroys your panel etc.)

What happens, in fact, the first time you run it and select some options (I know only one -- Preferences), it resets all the values to some default once incompatible with the Unity and Ubuntu 11.10 system. I do not know if this happens to everyone and under what conditions but this happened to me all the time I run ccsm on a new install.

If you run ccsm the first time, go to Preferences and wait couple minutes till it ends destroying everything around (the panel should disappear). Then either click Back in ccsm and manually set up all the plugins to the values you like (do not forget to check the Unity plugin), or import your profile from the Ubuntu 11.04. Either way, the next time you run ccsm, it stops destoying anything.

P.S. I have personally changed this key to < Alt >< Super >Button1 in CompizConfig. It works perfectly. BUT, I could not find a file containing this string in ANY folder starting with dot '.' in my home folder. I could not find it in dconf-editor either. So, I have no idea how to change this without CompizConfig.

share|improve this answer

If using Unity, hit "Alt+F2" and go: System Settings -> Keyboard -> Shorcuts. If using Gnome, can't remember the exact path but it would be something like System->Preferences->Keyboard Shorcuts.

Hope it helps.

Best regards,

share|improve this answer

You might want to check under /apps/compiz-1/ with gconf-editor.

share|improve this answer
    
Where do i have to disable alt-LMB (left mouse button) and what do i need to enter there? –  grenzfrequence Oct 26 '11 at 22:00
    
I tried to deactivate it in /apps/compiz-1/plugins/move/screen0/options/initiate_button. It was set to <alt>button1. I deleted <alt>button1 and made a reboot. But nothing changed, same behaviour. –  grenzfrequence Oct 26 '11 at 22:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.