Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was running 11.04 before upgrading to 11.10 recently and now I am not able to access my account. When I try to login, the console flashes up with some messages on it, then the NVidia logo pops up and then it takes me back to the login screen. I have a Latitude E6500.

I believe the issue stems from here: when using 11.04 I tried to get the cube working on Compiz against others recommendations. Eventually I hosed my CCSM settings and was not able to login to the account anymore without changing to Ubuntu Classic on the login menu. Now that Ubuntu classic is gone in 11.10 I'm only able to login through the guest account (to see a desktop at least, terminal is still fine).

I believe if I can reset my CCSM settings back to default through the terminal while logged into my main account that would fix it. Any ideas?

share|improve this question
possible duplicate of How can I reset compiz to the default settings? – Bruno Pereira Oct 25 '11 at 15:19
None of the suggested solutions below worked. Perhaps I have diagnosed the issue incorrectly? I logged into the guest account and tried the commands below through both a GUI terminal (ctrl+alt+t) and through a tty terminal (ctrl+alt+f1) logged into the account that does not work. I still get the same issue. Any ideas on how to even diagnose what may be causing this issue? – scott Oct 25 '11 at 17:14

If you're using Unity and you want to reset Unity to its default settings, want to reset the Unity Launcher icons or you've changed some Compiz settings which have messed up Ubuntu and want to reset everything, here's how to do it.

Reset Unity

If you want to reset Unity (this will only reset the Unity settings in CompizConfig Settings Manager and leave the other CCSM settings intact), open a terminal (or press ALT + F2) and enter:

unity --reset

Reset Unity Launcher icons

If you want to reset the Unity Launcher icons (dock bar on the left) to their initial state, run the following command:

unity --reset-icons

Reset Compiz

Warning: only do this if you really must and have no other option! Use both commands, or else you might not see the Unity launcher and top panel anymore! Use it at your own risk.

To reset all the Compiz settings (this includes all the plugins settings, etc.) to the default values, open a terminal (don't run it with ALT + F2! The top panel and launcher will disappear after running the first command but will show up after the second one so use a terminal) and type:

gconftool-2 --recursive-unset /apps/compiz-1
unity --reset

If something doesn't look right after this, log out and log back in.

share|improve this answer
+1 for being much easier than my solution. Just out of curiousity, does anything need to happen to /apps/compizconfig-1? – zpletan Oct 25 '11 at 15:03
Ubuntu Tweak also includes an option to reset the Gconf settings, starting with version 0.5.6. – hhlp Oct 25 '11 at 15:08
Compiz in Ubuntu >= 11.04 is a bit different then in older Ubuntu versions because its settings in gconf are under /apps/compiz-1 and not under /apps/compiz like before. – hhlp Oct 25 '11 at 15:09
--recursive-unset Resets the values of all preference keys, in all subdirectories in a directory, from the user setting to the setting in the default configuration source. – hhlp Oct 25 '11 at 15:14
this did not work unfortunately – scott Oct 26 '11 at 2:50

Maybe this will help you, or someone else: If nothing else works, install ubuntu tweak.

Use Ctrl+Alt+T then enter

sudo apt-get install ubuntu-tweak

Then go to admins>>Desktop recovery>>reset

This was the only solution that worked for me.

I did this after unity --reset and re-installing unity failed, and probably everything else I read off the net.

share|improve this answer

You might try this:

  1. Press Ctrl+Alt+F1 from the login screen, and then log in via the terminal that comes up.
  2. cd into ~/.gconf
  3. Remove[1] apps/compiz-1/, apps/compizconfig-1/, and apps/metacity/ (and perhaps desktop/).
  4. Press Ctrl+Alt+F7 to get back to the login screen, then log in. Has this fixed the problem?

[1] Preferably by copying them into a different directory so you can restore them later if you need to.

share|improve this answer
Downvoter, could you please explain what's wrong? – zpletan Oct 25 '11 at 15:53

If you can do that in a terminal press the keys ctrl+alt+F1 at the login screen to access a terminal, there you can login with your account and reset compiz to defaults with

gconftool-2 --recursive-unset /apps/compiz-1

If compiz was the issue this will reset your configuration and plugins back to default.

share|improve this answer
-1 for no specifics on how to actually reset. – zpletan Oct 25 '11 at 15:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.