Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On a fresh install when i run X -configure, i get this error:

X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-27-server x86_64 Ubuntu
Current Operating System: Linux ombre-Vostro-3550 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=/dev/sda3 ro quiet splash vt.handoff=7
Build Date: 13 October 2011  05:44:30PM
xorg-server 2:1.10.4-1ubuntu4.1 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.22.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Oct 25 20:44:05 2011
List of video drivers:
    ati
    cirrus
    vmware
    intel
    mach64
    mga
    neomagic
    nouveau
    openchrome
    qxl
    r128
    radeon
    s3
    savage
    siliconmotion
    sis
    sisusb
    tdfx
    trident
    vmwlegacy
    fbdev
    vesa
(EE) Failed to load module "vmwgfx" (module does not exist, 0)
(EE) vmware: Please ignore the above warnings about not being able to to load module/driver vmwgfx
(++) Using config file: "/home/ombre/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] No DRICreatePCIBusID symbol, no kernel modesetting.
Number of created screens does not match number of detected devices.
  Configuration failed.
 ddxSigGiveUp: Closing log

I do get an xorg.conf file but it seems empty(or defaulted) see below.

I have been fighting on this problem for days and i am really getting desperate, this is my first Linux experience and even though i learned a lot trying to solve issues i really wish i would get that fixed so i can finally use my computer.

Thank you all for any input you might have.

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    Screen      2  "Screen2" RightOf "Screen1"
    Screen      3  "Screen3" RightOf "Screen2"
    Screen      4  "Screen4" RightOf "Screen3"
    Screen      5  "Screen5" RightOf "Screen4"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "dbe"
    Load  "dri"
    Load  "dri2"
    Load  "extmod"
    Load  "glx"
    Load  "record"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor1"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor2"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor3"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor4"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor5"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "DRI"                   # [<bool>]
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "Shadow"                # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"          # [<bool>]
        #Option     "XvMC"                  # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "DebugFlushBatches"     # [<bool>]
        #Option     "DebugFlushCaches"      # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "RelaxedFencing"        # [<bool>]
    Identifier  "Card0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "SWcursor"              # [<bool>]
        #Option     "Dac6Bit"               # [<bool>]
        #Option     "Dac8Bit"               # [<bool>]
        #Option     "BusType"               # [<str>]
        #Option     "CPPIOMode"             # [<bool>]
        #Option     "CPusecTimeout"         # <i>
        #Option     "AGPMode"               # <i>
        #Option     "AGPFastWrite"          # [<bool>]
        #Option     "AGPSize"               # <i>
        #Option     "GARTSize"              # <i>
        #Option     "RingSize"              # <i>
        #Option     "BufferSize"            # <i>
        #Option     "EnableDepthMoves"      # [<bool>]
        #Option     "EnablePageFlip"        # [<bool>]
        #Option     "NoBackBuffer"          # [<bool>]
        #Option     "DMAForXv"              # [<bool>]
        #Option     "FBTexPercent"          # <i>
        #Option     "DepthBits"             # <i>
        #Option     "PCIAPERSize"           # <i>
        #Option     "AccelDFS"              # [<bool>]
        #Option     "IgnoreEDID"            # [<bool>]
        #Option     "CustomEDID"            # [<str>]
        #Option     "DisplayPriority"       # [<str>]
        #Option     "PanelSize"             # [<str>]
        #Option     "ForceMinDotClock"      # <freq>
        #Option     "ColorTiling"           # [<bool>]
        #Option     "VideoKey"              # <i>
        #Option     "RageTheatreCrystal"    # <i>
        #Option     "RageTheatreTunerPort"  # <i>
        #Option     "RageTheatreCompositePort"  # <i>
        #Option     "RageTheatreSVideoPort"     # <i>
        #Option     "TunerType"             # <i>
        #Option     "RageTheatreMicrocPath"     # <str>
        #Option     "RageTheatreMicrocType"     # <str>
        #Option     "ScalerWidth"           # <i>
        #Option     "RenderAccel"           # [<bool>]
        #Option     "SubPixelOrder"         # [<str>]
        #Option     "ClockGating"           # [<bool>]
        #Option     "VGAAccess"             # [<bool>]
        #Option     "ReverseDDC"            # [<bool>]
        #Option     "LVDSProbePLL"          # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "DRI"                   # [<bool>]
        #Option     "ConnectorTable"        # <str>
        #Option     "DefaultConnectorTable"     # [<bool>]
        #Option     "DefaultTMDSPLL"        # [<bool>]
        #Option     "TVDACLoadDetect"       # [<bool>]
        #Option     "ForceTVOut"            # [<bool>]
        #Option     "TVStandard"            # <str>
        #Option     "IgnoreLidStatus"       # [<bool>]
        #Option     "DefaultTVDACAdj"       # [<bool>]
        #Option     "Int10"                 # [<bool>]
        #Option     "EXAVSync"              # [<bool>]
        #Option     "ATOMTVOut"             # [<bool>]
        #Option     "R4xxATOM"              # [<bool>]
        #Option     "ForceLowPowerMode"     # [<bool>]
        #Option     "DynamicPM"             # [<bool>]
        #Option     "NewPLL"                # [<bool>]
        #Option     "ZaphodHeads"           # <str>
    Identifier  "Card1"
    Driver      "radeon"
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "Rotate"                # <str>
        #Option     "fbdev"                 # <str>
        #Option     "debug"                 # [<bool>]
    Identifier  "Card2"
    Driver      "fbdev"
    BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "Rotate"                # <str>
        #Option     "fbdev"                 # <str>
        #Option     "debug"                 # [<bool>]
    Identifier  "Card3"
    Driver      "fbdev"
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "DefaultRefresh"        # [<bool>]
        #Option     "ModeSetClearScreen"    # [<bool>]
    Identifier  "Card4"
    Driver      "vesa"
    BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "DefaultRefresh"        # [<bool>]
        #Option     "ModeSetClearScreen"    # [<bool>]
    Identifier  "Card5"
    Driver      "vesa"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen1"
    Device     "Card1"
    Monitor    "Monitor1"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen2"
    Device     "Card2"
    Monitor    "Monitor2"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen3"
    Device     "Card3"
    Monitor    "Monitor3"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen4"
    Device     "Card4"
    Monitor    "Monitor4"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen5"
    Device     "Card5"
    Monitor    "Monitor5"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Here is my hardware:

01:00.0 VGA compatible controller: ATI Technologies Inc NI Whistler [AMD Radeon HD 6600M Series]
    Subsystem: Dell Device 04cd
    Kernel driver in use: radeon
    Kernel modules: radeon

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    Subsystem: Dell Device 04cd
    Kernel driver in use: i915
    Kernel modules: i915

And here is my the xrandr -q output:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768       60.0*+   40.0  
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected (normal left inverted right x axis y axis)
   1680x945       59.9 +
   1600x900       60.0  
   1280x1024      75.0  
   1440x900       59.9  
   1024x768       75.1     72.0     70.1     60.0  
   800x600        72.2     75.0     70.0     60.3  
   640x480        72.8     75.0     70.0     60.0  
   720x400        70.1 
share|improve this question
1  
By default, the settings are autodetected so you shouldn't have a need for the xorg.conf file. Try removing it and see if it starts normally. –  Lekensteyn Oct 25 '11 at 13:15
    
I saw a comment about VMware in my inbox but for some reason it's not showing here. To reply to in, No i am not sure, i am not exactly clear about what that is actually. –  silkAdmin Oct 25 '11 at 13:16
    
@Lekensteyn I know though i think my problems comes from the automatically detection, as my displays keep on randomly changing resoltion and position, so i figured by hard coding the config i might solve that. –  silkAdmin Oct 25 '11 at 13:18
    
@Lekensteyn - that's the issue, it's not autodetecting properly. so the one it generates and runtime is not correct in some way. to overcome issues like this you typically generate an xorg.conf, save it, and tweak it to your needs(for example to over-ride the detected resolution for some hardware). –  hbdgaf Oct 25 '11 at 13:39
    
@aking1012 so that means that i have to rewrite the whole xorg.conf, cause with my 2 days linux experience it s gonna be tough. Do you think i can use the one i have as a basis? It doesn t seems to have any of my hardware in there –  silkAdmin Oct 25 '11 at 13:48
show 5 more comments

1 Answer

Try adding to this section:


Section "Module"
    Load  "dbe"
    Load  "dri"
    Load  "dri2"
    Load  "extmod"
    Load  "glx"
    Load  "record"
EndSection

to look like this:


Section "Module"
    Load  "dbe"
    Load  "dri"
    Load  "dri2"
    Load  "extmod"
    Load  "glx"
    Load  "record"
    Load  "radeon"
EndSection

I see that you have the radeon device, but nowhere does it say to load the driver. Another option would be to see if the closed source driver works if you run jockey-text from the command line.

I also think it's odd that it finds 5 displays.

share|improve this answer
    
Thanks aking, though was i wrong when i thought that the xorg.conf file listed above is just "empty" ? If so if i place it in my /etc/x11/ folder am i not going to crash my system ? (cause i usually when this happens i have to reinstall everything so kinda tedious) And also for 'I also think it's odd that it finds 5 displays.' Yes it is though i read somewhere that it tries to fill the virtual diaplys with as many screens as it can using the defautl screen as reference, right now my virtual display is like 8000 something, so might be why(was hoping to fix that in xorg.conf as well) –  silkAdmin Oct 25 '11 at 13:31
    
You can but the xorg.conf file in several places. if you put it in /etc/X11 and the Xorg process dies, it should just die. you could tell it not to start xorg on boot if it's a concern though –  hbdgaf Oct 25 '11 at 13:36
    
Thanks again for trying to help, though i tried all sorts of configuration for xorg.conf and nothing work.. –  silkAdmin Oct 26 '11 at 6:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.