Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried variety of methods to install to install / set the default Adwaita white theme to use the dark version. This works, the only problem is the title bar in my black version stays white unlike the dark color in the screen shots of the theme. This is very distracting as it contrasts to much with the rest of the theme and basically makes it unusable which is a pity as it is a very nice looking theme otherwise.

Any help / advice will be greatly appreciated.

share|improve this question

4 Answers 4

Have you installed and used Gnome Tweak Tool?

Install it by running into the terminal:

sudo apt-get install gnome-tweak-tool

Then run it by pressing the Win/Metakey and typing "gnome-tweak-tool".

Select the "Theme" tab on the left hand side and there should be an option to change the Window Theme via a drop down menu. Select it and then close the program. You may need to log out and log back in to see the effects.

If you can't see your Dark Adwaita theme in the drop down, then it may not have been installed properly.

share|improve this answer
    
Thanks for the reply. I can see and activate the theme. I log out and in again. All works perfectly except the graphical glitch in the theme where the title bar is still white and in extreme contrast to the rest of the theme. I have seen screen shots of the theme and in the screen shots the title bar of a window is also suppose to be dark. Adwaita and the dark variant are default gnome3 themes (actually it is the default theme). This is some kind of bug with ubuntu. I found another post about someone else with ubuntu as well experiencing the same issue... Maybe there is some css setting wrong? –  georgelappies Oct 25 '11 at 14:24

I guess this should actually be filed a bug in compiz (if it isn't already).

The windowborders are not corresponding to the dark theme-variant, because this functionality is only implemented in Mutter, not in Compiz/Metacity (yet).

share|improve this answer

I had the same problem in 11.10. Here is what I had done to fix this.

Go the desktop. Right-click -> Select Change Desktop Background -> Change Theme to be used for the UI to Ambiance. ( If it's already selected to Ambiance, then change it to something else, the again select Ambiance ). It worked for me after doing this. Hope this helps.

share|improve this answer

Where did you download Adwaita Dark from? I had some weird issues similar to what you are describing with the download link in a post from OMG! Ubuntu. I had better luck with an updated version of the theme from gnome-look.org

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.