Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday my apache server decided to don't run anymore and I don't now why. Every virtual host displays an 403-Error-Message like the following I copied from the log file:

[error] [client 127.0.0.1] (13)Permission denied: access to / denied

I think rights are set correctly, I prooved with ls -al /home/... And actually I didn't changed anything in the configuration:

<VirtualHost *:80>
ServerAdmin webmaster@localhost
ServerName webprojekte
DocumentRoot /home/tarea/Webprojekte/work
<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>
<Directory /home/tarea/Webprojekte/work/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
</Directory>
ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

By the way phpmyadmin is still working correctly. Thank you helping me!

share|improve this question
    
Please post ls -ld / –  Lekensteyn Oct 25 '11 at 9:54
    
Related: askubuntu.com/questions/14301/… –  Capt.Nemo Oct 25 '11 at 9:56

1 Answer 1

It is not the configuration, but the file permissions themselves. You need to chmod your web root directories to 755 and web files to 664.

A far better solution is to use the user module in apache, which allows user to host files inside a public_html folder in home directory.

for further information see:

Apache symlinked to home directory - Permission Errors

share|improve this answer
    
chmoding the files directory did't work. Nothing changed ... –  user30495 Oct 25 '11 at 10:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.