Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Having tried unity, GNOME 3, GNOME-Shell, XFCE, and OpenBox, I would finally like to get back to GNOME 2.x

Not being a hardcore Linux user, my best bet is to do a clean install of Ubuntu 11.04 with GNOME Classic (the real one) which worked very well for me.

Now how would I prevent the Update Manager to alert me with GNOME updates? I don't want to mistakenly reinstall GNOME 3 on top of ubuntu 11.04...

thank you very much

share|improve this question
add comment

1 Answer

GNOME 3 in Ubuntu 11.04 was very experimental, so the Ubuntu team didn't include an official repository for GNOME 3. If they did, it would have broke Unity in that release. It's only in Ubuntu 11.10 that they merged GNOME 3 with Unity, and hence GNOME 2 was ditched.

I'd say you have nothing to really worry about. Just as long as you stay away from the GNOME 3 experimental repo that Ubuntu gave out (you have to set that up manually), then you are safe with GNOME 2.

share|improve this answer
1  
Ubuntu typically does not upgrade to a newer release of GNOME after the final release for the reasons mentioned above. Again, so long as you are using 11.04 you will not be presented with an opportunity to upgrade to GNOME 3 unless you specifically add experimental PPAs or compile it yourself. –  WarriorIng64 Nov 7 '11 at 20:08
2  
Indeed, except through the natty-backports repository or PPA's, pretty much all the updates you receive in your Ubuntu 11.04 system will be fixes for security bugs or serious stability/usability bugs. The only exceptions to this are for software like the Chromium browser or Adobe's proprietary Flash player, where the only practical way to get fixes for those problems is to add new features and change the interface and available functionality too. See wiki.ubuntu.com/StableReleaseUpdates for details. –  Eliah Kagan Nov 7 '11 at 21:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.