Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I play music in Banshee, it gets to the end of a play queue or album then starts playing a seemingly random album.

For example, if I double click an album then it starts playing. At the end, it starts playing the play queue.

On the other hand, if I create a play queue and play through it, at the end it skips onto anther artist or album. It tends to be the album or artist that was last selected in the music browser but not always. Sometimes it will skip to track 2 or 3 as well (shuffle is not on).

How do I get Banshee to just play an album or a play queue then STOP?

share|improve this question
    
There is a "Stop When Finished" menu option, that, as Oli pointed out, will stop the playback after the current item (not the current playlist). –  Firefeather Oct 14 '10 at 15:04

2 Answers 2

up vote 1 down vote accepted

I have the same problem. I haven't found a fix and I'm pretty sure I logged a bug against this over a year ago (no idea where it is now).

However I have found a workaround. I call it that (rather than a fix) because it's a pain in the bottom.

  1. Restart Banshee
  2. Empty the Play Queue (Right click it, click clear)
  3. Double click the Play Queue
  4. Add tracks to the Queue
  5. Double click the Play Queue again to start playing.

I also assume you queue's fill mode is manual and it's not pulling in songs automatically. If you're not using manual mode, that might be your problem.

If you find a way of doing this without restarting Banshee, let me know... Not that I mind restarting Banshee... If it's running for too long it does tend to eat all my RAM.


Just noticed the other half to your question. If you have things in Play Queue they are supposed to play after the current track. That's by design. If you don't want them to play, clear the queue.

share|improve this answer

I think the behaviour described by the OP is caused by the gapless playback option. Disabling that option stops this very annoying glitch.

I appreciate this is an old question, but people may still find it while googling for this problem, as I did.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.