Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying for a while now to install openFrameworks on my 11.10. For those familiar with openFrameworks, a script called install_dependencies.sh is provided and it should install all dependencies that are needed by openFrameworks. When running the script after updating my OS to 11.10, it will eventually stop and these are the last lines that it outputs:

Package gstreamer-0.10 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gstreamer-0.10.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gstreamer-0.10' found
compiling object for  ../../../openFrameworks/video/ofVideoPlayer.cpp
mkdir -p obj/Debug/openFrameworks/video
g++ -g3 -Wall -fexceptions -I../../../FreeImage/include -I../../../assimp/include -                I../../../assimp/include/Compiler -I../../../cairo/include -I../../../cairo/include/libpng15 -I../../../cairo/include/pixman-1 -I../../../cairo/include/cairo -I../../../fmodex/include -I../../../freetype/include -I../../../freetype/include/freetype2 -I../../../freetype/include/freetype2/freetype -I../../../freetype/include/freetype2/freetype/config -I../../../freetype/include/freetype2/freetype/internal -I../../../freetype/include/freetype2/freetype/internal/services -I../../../glew/include -I../../../glew/include/GL -I../../../kiss/include -I../../../portaudio/include -I../../../rtAudio/include -I../../../tess2/include -I../../../poco/include -I../../../glu/include -I../../../openFrameworks/ -I../../../openFrameworks/events -I../../../openFrameworks/video -I../../../openFrameworks/3d -I../../../openFrameworks/sound -I../../../openFrameworks/utils -I../../../openFrameworks/types -I../../../openFrameworks/math -I../../../openFrameworks/communication -I../../../openFrameworks/app -I../../../openFrameworks/gl -I../../../openFrameworks/graphics   -MMD -MP -        MFobj/Debug/openFrameworks/video/ofVideoPlayer.d -    MTobj/Debug/openFrameworks/video/ofVideoPlayer.d -o obj/Debug/openFrameworks/video/ofVideoPlayer.o -c ../../../openFrameworks/video/ofVideoPlayer.cpp
In file included from ../../../openFrameworks/video/ofGstVideoPlayer.h:3:0,
                 from ../../../openFrameworks/video/ofVideoPlayer.h:9,
                 from ../../../openFrameworks/video/ofVideoPlayer.cpp:1:
../../../openFrameworks/video/ofGstUtils.h:5:21: fatal error: gst/gst.h: No such file or directory
compilation terminated.
make: *** [obj/Debug/openFrameworks/video/ofVideoPlayer.o] Error 1
there has been a problem compiling Debug OF library
please report this problem in the forums

I have gstreamer-0.10 installed and I've tried everything that I could find from people with similar issues, but yet I haven't been able to run that script to completion.

Would anyone have any suggestions?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The script in OF for ubuntu is a bit flawed for a user build & will not run the first 2 lines unless run from a root terminal.

They should or you can edit the script & add sudo to the beginning of the first 2 lines, as in -

sudo apt-get update
sudo apt-get install 'blah blah'

Then you can run from your normal user terminal prompt

Additionally while either libjack0/libjack-dev or libjack-jack2-0/libjack-jack2-dev can still be used, they/you should switch the dep to the latter which is more current.

share|improve this answer
    
I solved the problem a while ago by doing something like what you just described. –  Everaldo Aguiar Feb 23 '12 at 18:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.