Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since Oneiric, if I leave my machine (HP Mini 110 netbook) unattended and it goes into power-save mode, the backlight gets disabled. How can I turn it back on? Note that the keyboard backlight controls (Fn+F4 and Fn+F3) don't have any effect in this situation.

I've already filed a bug, but filing a bug doesn't fix my problem. I tried this workaround posted in this bug report dealing with Acer laptops:

sudo setpci -s 00:02.0 F4.B=0

However, if anything, that command makes things worse. In the general case, I can see a little bit if I'm in a dark room with a flashlight aimed just so. But after running setpci I can't see anything. And I find the setpci documentation to be utterly incomprehensible, so I don't know whether I need to tweak my command somehow or whether I'm completely barking up the wrong tree.

Update: I've found a workaround: I'm now booting with the kernel parameter acpi=off. This disables power management, which prevents the machine from going into power saving mode and thus failing to come back up correctly. Of course, not having power management means that I can't use suspend or do anything to manage power other than powering it off (even then, I have to manually use the power switch). Also, it prevents me from using Unity 3D or Gnome Shell, forcing me into Unity 2C or Gnome Classic. So, I'd really like to be able to stop using this hack.

Update 2: Midway through Oneiric's run, a kernel update fixed this issue. But this question is still relevant as a general procedure for working around showstopper kernel regressions.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

This is a kernel bug. There are two workarounds. The first is to boot with acpi=off as described in the question. The second is to boot with a Natty kernel. This is much better, though it seems to make LibreOffice a bit crashy.

share|improve this answer
add comment

Did you try hitting Fn+F4? This usually triggers the backlight to turn on

share|improve this answer
    
Good suggestion. Unfortunately, it didn't work for me. –  Scott Severance Oct 26 '11 at 1:48
    
Can you tell us what your F4 key is when you use the Fn key? It differs between mfr and models. –  lqlarry Oct 26 '11 at 2:54
    
@lqlarry: Fn+F4 should increase the brightness on this machine, and Fn+F3 should decrease the brightness. Neither key has any effect. –  Scott Severance Oct 26 '11 at 12:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.