Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my new ubuntu 11.10 install the Tomboy notes synchronizes just some of my notes notes and then fails. The details only shows the updated notes. When I look at the .config/tomboy/tomboy.log I see the error:

10/24/2011 11:12:29 PM [ERROR]: Synchronization failed with the following exception: A note with this title already exists: New Note Template
  at Tomboy.NoteManager.CreateNewNote (System.String title, System.String xml_content, System.String guid) [0x00000] in <filename unknown>:0 
  at Tomboy.NoteManager.CreateNoteFromTemplate (System.String title, Tomboy.Note template_note, System.String guid) [0x00000] in <filename unknown>:0 
  at Tomboy.NoteManager.CreateNewNote (System.String title, System.String guid) [0x00000] in <filename unknown>:0 
  at Tomboy.NoteManager.CreateWithGuid (System.String title, System.String guid) [0x00000] in <filename unknown>:0 
  at Tomboy.Sync.SyncManager+<CreateNoteInMainThread>c__AnonStorey11.<>m__3F () [0x00000] in <filename unknown>:0 
  at Tomboy.GuiUtils+<GtkInvokeAndWait>c__AnonStoreyC.<>m__2F (System.Object , System.EventArgs ) [0x00000] in <filename unknown>:0 

I have tryed changing the URL on the sync preferences to https://edge.one.ubuntu.com/notes/ as sugested in question 66753 but it did not work.

share|improve this question
add comment

3 Answers 3

up vote 9 down vote accepted

Not sure if I am supposed to answer my own question but I have managed to solve the problem.

Since the error on the log mentioned a note named "New Note Template" I created a note with that name through the ubuntu one web site and then tried to sync again. This time tomboy detected the conflict and offered some options to solve it. I chose to rename the local note and then it synced all my notes correctly!

share|improve this answer
4  
Answering your own question is perfectly acceptable. –  John Oct 26 '11 at 3:54
1  
Do you mind posting this bug on launchpad? Sadly, this is not the only tomboy related bug in Ubuntu 11.10 bugs.launchpad.net/ubuntu/+source/tomboy/+bug/883370 / askubuntu.com/questions/73429/… –  n3rd Nov 3 '11 at 6:10
    
I have added a comment on a bug that I believe is the same I got: bugs.launchpad.net/ubuntu/+source/tomboy/+bug/848250 –  lpanebr Nov 9 '11 at 11:15
add comment

Thanks 'lpanebr' for the reference to change server address in Tomboy Preferences to:

https://edge.one.ubuntu.com/notes/ note the addition 'edge' to the address

Sync proceeded OK.

share|improve this answer
    
This is not my merit. It goes to askubuntu.com/questions/71733/… thanks anyway! –  lpanebr Nov 9 '11 at 11:18
add comment

I opened the Tomboy Preferences, and on the first tab (Editing), clicked "New Note Template". I then renamed the Template title to "Title" instead of "New Note Template". Then closed this template note, and synchronization worked.

share|improve this answer
add comment

protected by Community Jan 21 '12 at 16:48

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.