Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've enabled the Canonical Partners sources, but my software centre (or apt-cache show skype) both only show skype 4.2.x, rather than the current 4.3.x

Sources such as this Ubuntu Handbook Article imply that 4.3 should be available through software centre.

I've run apt-get update and upgrade, so I think I'm all up to date.

I know I can install manually from the downloaded .deb from Skype's website, but why is my software centre out of date, and how can I get the latest to show up?

I'm running 14.04 LTS.

EDIT (from comments):

running: apt-cache policy skype yielded:

skype:
 Installed: (none)
 Candidate: 4.2.0.11-0ubuntu0.12.04.2
 Version table:
    4.2.0.11-0ubuntu0.12.04.2 0
        500 http://archive.canonical.com/ubuntu/ saucy/partner amd64 Packages
share|improve this question
    
Run sudo apt-get update and then run apt-cache policy skype and post the output to your question. – Pilot6 Jan 5 at 12:09
    
You added a repository for Ubuntu 13.10 saucy for some reason. If you replace saucy with trusty, you will get the correct version. – Pilot6 Jan 5 at 12:50
up vote 6 down vote accepted

You added the partner repository for Ubuntu 13.10. That was wrong. It can be fixed this way:

Run in terminal

sudo sed -i 's/saucy/trusty/' /etc/apt/sources.list
sudo apt-get update
sudo apt-get install skype

This will install the correct version.

Or you can got to System Settings -> Software & Updates and fix it there.

share|improve this answer
    
Brilliant, thanks. I now just have to worry about why/when I configured the wrong source :) – Andrew M Jan 5 at 13:53
4  
You probably ran some outdated command. – Pilot6 Jan 5 at 13:54
  1. Remove the old Skype version
sudo apt-get remove skype skype-bin:i386 skype:i386
sudo apt-get install sni-qt:i386
  1. Remove the old Skype folder
rm -rf ~/.Skype
  1. Enable MultiArch if you are running 64-bit Ubuntu
sudo dpkg --add-architecture i386
  1. Since you have already enabled Canonical Partners, run the update.
share|improve this answer
    
I'm afraid this hasn't helped, software centre and apt-cache both still show 4.2x (the older version). Thanks. – Andrew M Jan 5 at 12:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.