Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated to Oneiric a few days ago and my nfs shares will not connect as they always have with Natty on this and other computers on my network.

The error message is:

mount.nfs: rpc.statd is not running but is required for remote locking.
mount.nfs: Either use '-o nolock' to keep locks local, or start statd.
mount.nfs: an incorrect mount option was specified

So i did a clean install, copying in the fstab etc that worked on Natty on this box, but get the same error. No auto mount on boot, and when i do for example sudo mount /nas/mydocs

Have tried -o nolock with no success

fstab has lines like this, all working before upgrade

192.168.6.15:/johnsstore /home/john/nas/mydocs nfs rw,auto

sudo start statd
start: Job is already running: statd

rpcinfo

   program version netid     address                service    owner
    100000    4    tcp6      ::.0.111               portmapper superuser
    100000    3    tcp6      ::.0.111               portmapper superuser
    100000    4    udp6      ::.0.111               portmapper superuser
    100000    3    udp6      ::.0.111               portmapper superuser
    100000    4    tcp       0.0.0.0.0.111          portmapper superuser
    100000    3    tcp       0.0.0.0.0.111          portmapper superuser
    100000    2    tcp       0.0.0.0.0.111          portmapper superuser
    100000    4    udp       0.0.0.0.0.111          portmapper superuser
    100000    3    udp       0.0.0.0.0.111          portmapper superuser
    100000    2    udp       0.0.0.0.0.111          portmapper superuser
    100000    4    local     /run/rpcbind.sock      portmapper superuser
    100000    3    local     /run/rpcbind.sock      portmapper superuser
    100024    1    udp       0.0.0.0.138.56         status     114
    100024    1    tcp       0.0.0.0.228.44         status     114
    100024    1    udp6      ::.236.85              status     114
    100024    1    tcp6      ::.142.26              status     114
share|improve this question

closed as too localized by jrg Mar 6 '12 at 15:54

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Try adding the nfsvers=3 parameter in fstab. 192.168.6.15:/johnsstore /home/john/nas/mydocs nfs rw,auto,nfsvers=3 –  enedene Dec 5 '11 at 21:08
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  Ringtail Feb 26 '12 at 5:33

Browse other questions tagged or ask your own question.