Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Switch to another virtual desktop after unmaximizing a windows (Firefox, dconf-editor), and then return to the previous virtual desktop. Firefox becomes maximized again. How do I stop it???

I've tried setting Desktop > Unity > 'Form Factor' to desktop as suggested in Prevent Unity from auto-maximizing

I've also tried stuff from How to keep programs from launching maximized?, in particular: gconftool -s /apps/metacity/general/auto_maximize_windows -t bool false

None of that works.

Please read the question before marking it as a duplicate.
Please don't suggest CCSM, this is Unity2d.

share|improve this question
1  
What version of Ubuntu are you using? Can you verify that the gconftool command worked? Log out, log in again, run gconftool -g /apps/metacity/general/auto_maximize_windows (or use gconf-editor if you prefer a GUI). –  htorque Nov 5 '11 at 11:50
    
I was using Oneiric at the time, and actually had that info in the original title, but it was edited out by someone. Obviously, I've used gconf-editor and logged out/in. –  mikewhatever Nov 6 '11 at 6:53
    
Have you confirmed the setting was 'false' after you've logged back in? Just want to make sure that's working right. Also, you could try the same with a new user to confirm that it's not some issue with your user's configuration. –  htorque Nov 6 '11 at 9:18
    
If I had not confirmed the settings, I would not be posting the question. The installation was a fresh one with no original user settings changed. Unity2d maximizes windows by design, not because of something the user did. Do you have a verified solution that works? If not, can you try and test them. –  mikewhatever Nov 6 '11 at 9:32
    
No, I cannot reproduce your issue. If I set 'auto_maximize_windows' to 'false', the window sizes stay untouched. :-/ –  htorque Nov 6 '11 at 9:52
add comment

2 Answers 2

I had exactly the problem described and setting /apps/metacity/general/auto_maximize_windows to false worked for me! (11.10 [Oneiric] with Unity2D)

share|improve this answer
add comment

After

gconftool -s /apps/metacity/general/auto_maximize_windows -t bool false

subsequently

gconftool -g /apps/metacity/general/auto_maximize_windows

returned

false

and the auto-maximize stopped occuring after log out-log in. (Ubuntu 11.10 Unity2D)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.