Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to disable the touchpad while I type on my Aspire one netbook. If I issue the command syndaemon the synaptics driver is not detected:

Unable to find a synaptics device

So, I added the following to my xorg.conf file:

Section "InputDevice"
Identifier "Mouse0"
Driver "synaptics"
Option "Protocol" "auto"
Option "Device" "/dev/input/mouse0"
Option "ZAxisMapping" "4 5 6 7"
Option "CorePointer"
Option "HorizEdgeScroll" "1"
EndSection

It is still unable to find a synaptics device, however my touchpad works fine.

share|improve this question
    
Is there a way to force ubuntu to recognize my touchpad, so that I can deactivate it as reccomended. I guess the touch pad is currently emulating a mouse and so is not shutting off while typing –  Glen Oct 15 '10 at 16:36
1  
Please use the synaptics tag instead of synaptic to put your question in the list of Synaptics (touchpad) questions, rather than with the Synaptic Package Manager questions. (Oh how I long to have 200 rep so I can just do this housekeeping myself.) –  dgw Dec 16 '10 at 2:07
    
I had the exact problem with Asus K53S laptop and xserver-xorg-input-synaptics 1.4.1-1, touchpad isn't recognized and thus can not be turned off. After i upgraded to 1.5.0-2, everything works as it should. I suggest to either upgrade to the newest version or to send a bug-report as wiki.ubuntu.com/DebuggingTouchpadDetection suggests. –  sindikat Feb 25 '12 at 14:44

5 Answers 5

You may try reverting the change you did (or keeping it) and installing the gpointing-device-settings Install gpointing-device-settings package, which will provide more configuration options for your touchpad. Since Ubuntu 10.04 LTS this package replaces gsynaptics, if I remember well.

Once installed you can find it under System -> Preferences -> Pointing Devices.

share|improve this answer

from https://help.ubuntu.com/community/SynapticsTouchpad

The following example invokes syndaemon for 4 seconds after any keyboard activity (-i 4), except when modifier keys such as Alt or Shift are used (-K), and only disables tapping and scrolling (-t) for this period.

syndaemon -i 4 -d -t -K

add this to your Startup Applications

share|improve this answer
    
This should be chosen as answer. –  wakeup Apr 27 '13 at 17:45

on my lap-top I just go to the System > Prefrences > Mouse and under the Touchpad tab make sure Disable touhpad while typing is checked... after that it automatically disable the touchpad whenever I am typing... pretty cool if you ask me...

share|improve this answer

On my Aspire One netbook, I can just use Fn+F7 to disable and enable the touchpad.

share|improve this answer
    
thanks, but I really don't want to be pressing some key combination all the time. I'd like it to be automatically disabled briefly when typing. –  Glen Oct 14 '10 at 14:06
1  
Do you use Gnome or KDE? –  txwikinger Oct 14 '10 at 14:10

Some touchpads emulate a mouse in their hardware/firmware, and because of that still (partially) work even if they aren't recognized as "touchpads".

If GNOME detects a touchpad, it will show the tab in the Mouse preferences as TheX explains.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.