Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed 11.10 via Wubi on my Toshiba NB-205 netbook (Intel Atom N280 / 1.66 GHz, 1GB RAM, Mobile Intel 945GSE Express). After the initial boot and login, which went fine, I was checking out the desktop when the cursor froze. I could navigate with the keyboard but it appeared that the touchpad was not working. I restarted the netbook and after grub was chain-loaded and Ubuntu was selected, booting appeared to hang on a blank purple screen. After about five minutes lightDM appeared and I could login normally; also the touchpad was working normally. I checked to see if there was a driver that needed to be installed in case the touchpad was causing boot issues but no proprietary drivers are found via Additional Drivers. After reading similar problems, with no working solutions, it seemed it was a good idea to see if dmesg held any clues. Admittedly, I am not sure what to look for. I did notice the following lines:

[ 0.263568] pci0000:00: ACPI _OSC failed (AE_NOT_FOUND), returned control mask: 0x1d

[ 0.263575] ACPI _OSC control for PCIe not granted, disabling ASPM

I do not know if that is normal. Additionally, this popped up a few times:

EXT4-fs (loop0): re-mounted. Opts:

Basically, I just searched for "fail" and "error" in a text editor and those are what were found. Does anyone have any clue what may be causing the long boot time?

Thank you for your time.

share|improve this question
Install bootchart. Then after your next boot look in /var/log/bootchart for a nice picture of your boot. You can probably find out what's taking so long from that. – Kris Harper Oct 24 '11 at 18:33

Checking this it indicates you should use the kernel boot option nohz=off. It's also described in this bug. Since the bug indicates the problem is in the bios, you could try updating the bios and see whether Toshiba have fixed it.

share|improve this answer
Yes that seemed to do the trick. I was unaware of that page and whether or not it still applied. Thank you. – SamC Oct 24 '11 at 21:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.