Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Asus 22" widescreen monitor with resolution: 1680x1050, and another Samsung 19" with resolution: 1280*1024. I use my Asus as primary display, and want to use my Samsung monitor as streched desktop, but when I activate the secondary display, it works only in twinview mode (it works correct). But when I try to use it in separate X mode, in different resolution, all the things (Unity launcher, gnome panel (top bar), and window borders) missing. If I restart the system (only reset works) the login screen appears, but can't login, because the loginscreen freezes after typing password and hitting enter. I can login with Ubuntu 2D. Without closed nVidia drivers the extended desktop mode works correct (under display menu). Is there any way to make it work? What did i wrong? I'm using nVidia 9600GT in my system, with Ubuntu 11.10.

Thanks in advance.

share|improve this question
    
This is a bug –  Marco Ceppi Nov 15 '11 at 22:52
add comment

closed as off topic by Marco Ceppi Nov 15 '11 at 22:52

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 1 down vote accepted

Somehow, I experience the same. But using "Twinview" option does the opposite (extended).

Give this a try and if this is the case, then nVidia has something to do with this. Or is it an Ubuntu related issue?

Here you can see my nvidia-settings monitors arrangement with the "Twinview" configured but as you can notice in the screenshot, my desktop is extended.

enter image description here

BTW: I don't know how can this be fixed or if possible. But it works this way and it is good for me.

Good luck!

share|improve this answer
    
Thank you for the answer. I wonder if it works at different resolutions. I'll give a try again, but i've noticed, with Twinview option switched on, i have Unity menu on each screen, and top menu as well, looks like i'm having clone mode switched. –  kriszpontaz Oct 24 '11 at 18:11
    
Reinstalled closed drivers, and it seems to work with your workaround. Thank you. (I have two top menus each screen, this is a little bit weird.) –  kriszpontaz Oct 24 '11 at 18:48
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.