Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

HP laptop upgraded from 10.10 to 11.10, model DV2104. I used a wired connection for the install, but now it does not even seem to recognise that there is a wireless card. I think I need help with this one.

Question input on another connected device!

Installed WICD & WICD network manager & removed network manager - using Software Centre. Wired connection is OK, but WICD NM says there are no wireless networks available although I am less than 6ft from a (working) wireless router.

The hardware wireless switch on the HP is at left for on, but the light shows orange ! (it's normally blue when connected wirelessly)

STUMPED !!

share|improve this question
    
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information? –  Jorge Castro Oct 24 '11 at 17:10

2 Answers 2

I had this problem with a HP DV5000 series laptop, so it may not be the same as yours, but maybe you can use some of the steps to get you in the right place.

1st you need to identify your driver, and they way I do that is get a list of my hardware on my computer. Open terminal and see if the program that you need is installed. More than likely it is.sudo apt-get install lshw lshw is a Hardware Lister. If and when the program is loaded, now you can send a copy of your hardware to your home folder and you can save it in you Ubuntu One or Dropbox folder to keep as long as you have your laptop. Now in terminal type sudo lshw -html > your-file-name.html and if you want you can change where it says your-file-name to whatever you want. When the program is complete just go to your home folder and open the html file created. It should open with Firefox, Chromium, Chrome... When it is open, scroll down to where your wireless lan controller, it should look like this. enter image description here Under configuration on my laptop it says its a b43 driver. Now I downloaded the older Synaptic Package Manager in the USC (Ubuntu Software Center). After downloading I opened the Synaptic Package Manager a did a search on B43 and this is what I got; enter image description here Notice what choices I made and the choices I did not make. If we are lucky and the drivers are same, all should work. If you have a different driver then search what your driver is. With a little good luck it should work.

share|improve this answer

Have you tried to install WICD? It worked great for me! Download and install it, then remove network-manager.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.