Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu One together with the indicator for the panel on two differnt laptops (installed the same way). On one laptop Ubuntu One connection is started automatically after login where on the other it isn't.

How can I get the behaviour of Ubuntu One not being connected automatically after login?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

I solved the problem myself. I had to create an ubuntuone-launch.desktop file in /home/username/.config/autostart with the following text in it.

[Desktop Entry]
Name=Ubuntu One
Exec=/bin/sh -c '[ -d "$HOME/Ubuntu One" ] && ubuntuone-launch'
Type=Application
X-GNOME-Autostart-Delay=30
Icon=ubuntuone
Comment=
X-Ubuntu-Gettext-Domain=ubuntuone-client
Hidden=true
X-GNOME-Autostart-enabled=false
Name[de]=ubuntuone-launch.desktop

That prevents UbuntuOne from automatically establishing a connection after login. (Checked by removing the .desktop file)

share|improve this answer

On the top right menu where you can shut down your computer, you'll find Startup Applications. This is where you can uncheck Ubuntu One to start after login.

share|improve this answer
    
Ubuntu One is not in the startup applications, only Ubuntu One indicator which is intended to start. I want to have the indicator running after but not a connection after login. –  joschi Oct 24 '11 at 16:24
    
really? for me, its ubuntu one itself i guess. So i understand you right, you want ubuntu one to start but not to automatically connect? –  Dominik Oct 24 '11 at 16:27
    
Right, I don't want Ubuntu One connect automatically after login. In the startup applications there's only the indicator autostart entry that's generated automatically after installation of the indicator. I don't understand why on one laptop it doesn't connect automatically but on the other it does? (as I did the same things) –  joschi Oct 24 '11 at 16:45
    
well, then im sorry i cant help you. –  Dominik Oct 25 '11 at 11:21

I am not really sure I understand what you are trying to do.

There is no way, from the UI, to disable autoconnection. There is a way to do that by editing a config file.

It's probably easier not to start Ubuntu One.

share|improve this answer
    
I don't start Ubuntu One. All I autostart is the indicator to be able to access Ubuntu One quickly (as I said I have two different behaviours on the differnt laptops). Which config file do I have to edit? –  joschi Oct 24 '11 at 17:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.