Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 11.10 running on a system76 laptop. without the proprietary driver i was able to set up a second monitor (samsung 19") with extended display.

when i activate the proprietary driver, the only display setting that works is "mirror". when i pick to extend the display at the proper resolution (1280:1084, samsung) (1600:900, laptop) for each screen I get the following:

required virtual size does not fit available size: requested=(2880, 1024), minimum=(320, 200), maximum=(1600, 1600).

when i try to execute the resolutions that are set at default, after unchecking the "mirror screens" button (1152:864, samsung) (1600:900, laptop) i get the following:

requested position/size for CRTC 148 is outside the allowed limit: position=(1152, 0), size=(1152, 864), maximum=(1600, 1600)

share|improve this question
    
bogdan's answer here: link works to get the dual monitors working, but it reverts back to mirroring the screens at low resolution upon reboot. configuring the screens messes up my synergy setup (mouse controlled by the server only goes partway across the first screen) so configuring at each boot is not a good workaround for me. any suggestions? –  kenneth dyson Oct 24 '11 at 14:02
    
ok, think i got it working now. used administrator version of amd catalyst control center. set up dual screen display, laptop (1) right - samsung (2) left. set each display to recommended resolution. clicked apply. monitors worked, but synergy messed up. logged out and back in. back to mirrored screens at low resolution. went to displays in the systems menu. unticked mirror screens, set resolutions of each monitor to recommended, and it set up nicely, but synergy messed up again. logged out and back in....low and behold dual monitors with proper resolution set and synergy working fine! –  kenneth dyson Oct 24 '11 at 14:15
    
Same problem, last post in this topic ubuntuforums.org/showthread.php?t=1855750 solved my problem. –  user30814 Oct 26 '11 at 21:37
add comment

2 Answers 2

Type in this command, to open the AMD Catalyst Control Center

gksudo amdcccle
  1. Go to Display manager > There you must see your monitors.
  2. Click on the Monitor you want to setup display on
  3. Go to Multiple Screen Tab
  4. Change the display mode to your choice
  5. Apply this and restart
share|improve this answer
3  
Should be accepted as an answer! I never even knew this was installed by default. I'm on an iMac running Ubuntu 12.04 and saw the need when the generic "Displays" threw the error mentioned in the OP. I was connecting the iMac to an external Cinema Display. The Catalyst Control Center solved this. –  TryTryAgain Mar 1 '13 at 1:38
add comment

Open a terminal and type:

gksudo gedit /etc/X11/xorg.conf

In the sub-section "display" add this code or modify if already exist:

virtual 2880 1024

Where 2880 and 1024 are the value returned by the error: required virtual size does not fit available size: requested=(2880, 1024), minimum=(320, 200), maximum=(1600, 1600).

Restart the computer.

Then you will be able to extend your desktop without issue.

share|improve this answer
    
This works. One additional thing that you need to do is restart the machine. –  SB. May 1 '12 at 4:24
    
Thank's edited my answer. –  01BTC10 May 1 '12 at 4:42
    
The Display subsection should be a child of the Screen section. See askubuntu.com/a/75546/81211 –  z0r Aug 26 '13 at 1:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.