Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have old graphics card - Radeon X1650 Pro, (which is not supported by ATI for Ubuntu 11.10).

I've checked Unity support by following command:

/usr/lib/nux/unity_support_test -p

And I've got yes in all options.

However when I'm trying to play some games - 3D is very pure.

So I wonder is it possible to fully enable its 3D acceleration somehow? Or do I already have its maximum in my Ubuntu 11.10?

share|improve this question
    
What games are you playing, are you using wine for them? –  Bruno Pereira Oct 24 '11 at 11:59
    
No, not Wine. I'm running games from Desura. And I've tried Braid for Linux, World of Goo, Hammerfight, Steel Storm - all is running real slow, 3D is scary :( –  kottenator Oct 24 '11 at 12:31
    
Quick one: are you using Ubuntu3D or Ubuntu2D desktop? Have you tried running the same games using Ubuntu2D desktop? –  Bruno Pereira Oct 24 '11 at 13:06
    
I'd tried to run Braid in Ubuntu 2D - it's faster than in Ubuntu 3D (thanks for advice ;) but too slow anyway. –  kottenator Oct 24 '11 at 13:50
    
That can be, but I am guessing the open source drivers are just that, slow compared with the ATI ones. –  Bruno Pereira Oct 24 '11 at 13:54

1 Answer 1

up vote 2 down vote accepted

You card needs to use the open source drivers that are not as fast as the ATI ones. Since ATI does not support your card anymore in Linux there is not much you can do.

Taken from wiki.cchtml.com:

Radeon (Catalyst Legacy & Open Source)

ATI/AMD dropped Catalyst support for these cards in Catalyst 9-4. These cards are supported with the legacy ATI 9-3 Catalyst release, but you MUST use a kernel 2.6.28 (or earlier) and Xserver 1.5 (or earlier). For example, you can use Catalyst 9-3 if you're running Ubuntu 8.04 or Debian Lenny/5.0. Open source support is good and 3D is still improving.

  • RV530/RV560 Radeon X1600/X1650/X1700, M56, M66

Running your games with compiz disable (or using Ubuntu2D instead of the default Ubuntu desktop) will help but not by much.

Think that is all you can try.

share|improve this answer
    
Thanks! Finally I can rest from continuous search for this answer. –  kottenator Oct 24 '11 at 14:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.