Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Ubuntu 11.10 , i'm unable to see any USB device in VirtualBox , although i had the ext package installed , which is downloaded from oracle's site today.

share|improve this question
up vote 12 down vote accepted

The most usual cause of this problem is that you have not added your user to the vboxusers group.

Note that gnome 3 (what 11.10 uses) has removed the ability to add groups from their user management applet. See this question to use the old GUI tool or use the command line.

You will need to log-ou and log-in again to be able to use USB under VirtualBox.

share|improve this answer
The correct name of the group is vboxusers. – enzotib Oct 24 '11 at 12:28
did a sudo usermod -a -G vboxusers $USER , solved the problem , kudos for you guys ;-P – warl0ck Oct 24 '11 at 12:42
@enzotib: Thanks, corrected. – Javier Rivera Oct 24 '11 at 13:25

I also faced the same problem but I got the solution and it worked, just type this command

sudo usermod -a -G vboxusers username

For further information follow the link

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.