Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Mutt for gpg-signed email. With previous versions of Ubuntu I could tell Mutt to use gnome-gpg, which would ask for my GPG passphrase with a GUI window and then store it my GNOME keyring for 24 hours or until logout, whichever came first. However gnome-gpg was removed from universe in Ubuntu 11.10. Is there a replacement?

share|improve this question
add comment

3 Answers

up vote 5 down vote accepted
+100

The default keyring manager for GNOME is seahorse:

Seahorse is a front end for GnuPG — the Gnu Privacy Guard program — that integrates to the GNOME desktop. It is a tool for secure communications and data storage. Data encryption and digital signature creation can easily be performed through a GUI and Key Management operations can easily be carried out through an intuitive interface.

(man 1 seahorse)

It should be enabled/running by default in Ubuntu and you should have this variable in your environment:

$ echo $GPG_AGENT_INFO
/tmp/keyring-XXXXXX/gpg:0:1

/tmp/keyring-XXXXXX/gpg is a socket bound by the program gnome-keyring-daemon, which is found in the gnome-keyring package.

Unfortunately, I don't have enough information about your system and I cannot tell you how to proceed exactly. However I should have given you enough information to start investigating the problem. If you need more help, please tell me whether you have the package installed, whether the process is running, whether the socket exists and whether the environment variable is set.

share|improve this answer
    
Looks like all I needed to do was remove the custom set pgp_sign_command="gnome-gpg ..." setting from my ~/.mutt/muttrc! –  Marius Gedminas Mar 17 '12 at 21:15
    
The embarrassing thing is that I did that ages ago, and seahorse-agent was working fine on my laptop. I send most of my mail from my work account using mutt over ssh -- and ssh doesn't forward the GPG_AGENT connection, so I was typing in my passphrase multiple times a day anyway, without noticing I didn't have to do that for the rare personal email. Whops. –  Marius Gedminas Mar 17 '12 at 21:18
add comment

I think on 11.10, installing seahorse-plugins should do this for you. And I think in 12.04 and newer versions, the gpg integration will be built-in. I used to have to install seahorse-plugins to make this work in older Ubuntu versions, but on 12.04 I don't have such a package installed, and the GPG integration is working fine for me.

share|improve this answer
    
I'm on 11.10. I don't have seahorse-plugins installed. I have GPG_AGENT_INFO in my environment. I don't seem to have any seahorse processes running, though... I think gnome-keyring-daemon is acting as a GPG agent for me. –  Marius Gedminas Mar 17 '12 at 21:21
    
Right. I'm not sure exactly what the plugins package does exactly, on a technical level. I never dug into the code to find out. I do know that not having it installed on older Ubuntu versions, would break the gpg+gnome-keyring integration on my systems. And I use gpg a lot with bzr and evolution. –  dobey Mar 18 '12 at 12:37
add comment

Gnome-GPG won't be avaiable for Ubuntu soon, but you can download the last builds that were made:

https://launchpad.net/ubuntu/+source/gnome-gpg

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.