Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My hardware can handle Compiz fine, but not Unity 3D, annoyingly enough. I hate Metacity more than Unity 2D, so I switched compositors using compiz --replace. However that leaves me with two problems:

  1. compiz --replace is temporary, it will revert back to Metacity, by the next reboot/login
  2. Compiz leaves window decorator when the windows are maximized.
share|improve this question
    
... I think this is the same question... the bounty could be yours! askubuntu.com/questions/70408/… –  fossfreedom Oct 24 '11 at 16:25
    
@fossfreedom Answered with the window decorator part there. –  Oxwivi Oct 24 '11 at 16:49

1 Answer 1

up vote 15 down vote accepted

Compiz as default Unity 2D compositor

Go to a Terminal and enter:

sudoedit /usr/share/gnome-session/sessions/ubuntu-2d.session

In the fifth line, change metacity to compiz:

DefaultProvider-windowmanager=compiz

Remove window decoration from maximized windows

To solve the window decorator issue, simply run the following in the terminal or Alt+F2 and the window decoration will immediately disappear:

gconftool-2 -s -t string '/apps/compiz-1/plugins/decor/screen0/options/decoration_match' '!state=maxvert'

The same can be done using the CompizConfig Settings Manager, CCSM, if you've installed it already:

enter image description here

share|improve this answer
    
Other places have suggested to use !(state=maxvert & state=maxhorz) instead, since that will activate it only for fully maximized windows, instead of partially ones –  isaaclw Feb 23 '13 at 15:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.