Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm investigating tweaking my power consumption performance on Ubuntu. When I run Powertop, the output seems strange, and not much like any of the screenshots I see on the web. That might be explained by recent version changes, but one thing seems wrong: the critical "wakeups/second" figure is 0.0.. Can this be right?

Here's the 'Overview' output:

Summary: 0.0 wakeups/second,  0.0 GPU ops/second and 0.0 VFS ops/sec

            Usage Events/s Category Description
         24.1 ms/s       0.0        Process        /usr/lib/nspluginwrapper/i386/linux/npviewer.bin --plugin /usr/lib/flashplugin-
         10.8 ms/s       0.0        Process        /usr/lib/firefox-7.0.1/plugin-container /var/lib/flashplugin-installer/npwrappe
          9.3 ms/s       0.0        Process        /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
          7.7 ms/s       0.0        Process        powertop
          5.2 ms/s       0.0        Process        /usr/bin/gnome-shell
          3.4 ms/s       0.0        Process        /usr/lib/firefox-7.0.1/firefox
          2.6 ms/s       0.0        Process        gnome-terminal
          1.9 ms/s       0.0        Interrupt      [47] i915
          1.9 ms/s       0.0        Timer          hrtimer_wakeup
          1.7 ms/s       0.0        Process        /usr/lib/udisks/udisks-daemon
 [etc, etc]

Idle stats as follows:

          Package   |             Core    |             CPU 0               CPU 1
POLL        0.0%    | POLL        0.0%    | POLL        0.0%    0.0 ms      0.0%    0.0 ms
C1-SNB      0.9%    | C1-SNB      1.2%    | C1-SNB      1.4%    0.4 ms      1.0%    0.4 ms
C3-SNB      0.5%    | C3-SNB      0.7%    | C3-SNB      0.8%    0.6 ms      0.6%    0.6 ms
C6-SNB      0.1%    | C6-SNB      0.1%    | C6-SNB      0.1%    0.6 ms      0.0%    0.8 ms
C7-SNB     96.0%    | C7-SNB     94.5%    | C7-SNB     93.7%    3.0 ms     95.4%    5.2 ms

                |             Core    |             CPU 2               CPU 3
                | POLL        0.0%    | POLL        0.0%    0.0 ms      0.0%    0.0 ms
                | C1-SNB      0.7%    | C1-SNB      0.6%    0.5 ms      0.7%    0.4 ms
                | C3-SNB      0.3%    | C3-SNB      0.2%    0.2 ms      0.4%    0.5 ms
                | C6-SNB      0.1%    | C6-SNB      0.0%    0.6 ms      0.1%    0.9 ms
                | C7-SNB     97.4%    | C7-SNB     97.6%    6.3 ms     97.2%    7.1 ms

Frequency stats show 0.0% for everything, and Device stats seem to have loads at 100%

          Usage     Device name
          5.7%        CPU use
         86.7%        Display backlight
         65.1%        Display backlight
        100.0%        USB device: xHCI Host Controller
        100.0%        USB Device: usb-device-8087-0024
        100.0%        PCI Device: Intel Corporation Centrino Advanced-N 6230
        100.0%        Radio device: Sony Notebook Control Driver
        100.0%        USB device: EHCI Host Controller
        100.0%        PCI Device: NEC Corporation uPD720200 USB 3.0 Host Controller
        100.0%        Radio device: iwlagn
        100.0%        PCI Device: Realtek Semiconductor Co., Ltd. RTS5116 PCI Express Card Reader
        100.0%        USB device: xHCI Host Controller
        [etc, etc]

So, my question is: is something wrong? I assume powertop is mis-reporting some things, right? I'm running on a Sony Vaio, and they're notorious for being difficult hardware for linux...

share|improve this question

closed as off-topic by Volker Siegel, Eric Carvalho, Jan, Afshin Hamedi, muru Nov 21 '14 at 18:22

  • This question does not appear to be about Ubuntu within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

This question appears to be off-topic because it is about a bug, as it turned out and is described in the answer. It was filed long time ago, and fixed since. – Volker Siegel Nov 15 '14 at 11:53

This appears to be a bug in PowerTop (I see the same behaviour on my Ubuntu 11.10 64-bit system). It has already been reported in Launchpad:

If you're interested in tracking progress towards fixing this, I suggest subscribing to the bug report.

share|improve this answer
thanks James - that looks like the same issue. maybe i'll try getting an older version... – hwjp Oct 24 '11 at 7:46

I figured out that I needed an extra library, and there are some libraries there that I don't need, but I just pop them into the terminal just in case. I made a little script that installs all these libraries, installs powertop 1.13 and runs it, but you will need to authenticate yourself at some point when it's running.

Simply copy and paste the following script into a text editor and save it with .sh at the end, e.g., and run it in terminal with sh Or if you do sudo sh, then I think it will remove the need to authenticate yourself. By the way, I don't consider myself to be an experienced user of Linux, although I have tried a few different distros and can do basic things with the command line. So if I have made a mistake, please forgive me. :)

tar -xvf powertop-1.13.tar.gz
sudo apt-get install libncurses5 libncurses5-dev libncursesw5 libncursesw5-dev gettext
cd powertop-1.13
sudo make install
sudo powertop
share|improve this answer
up vote 0 down vote accepted

Thanks to James for pointing me towards the reported bug in the ubuntu packaged version.

I downloaded the latest version, compiled from source, and things are looking more normal. Here are some instructions, for anyone that wants to have a crack (including a couple of dependencies I came across)

Install two dependencies:

sudo apt-get install libncurses5-dev
sudo apt-get install libncursesw5

get the latest version from

follow their instructions

for me, it worked out something like this:

tar -xvf powertop-1.13.tar.gz
cd powertop-1.13
sudo apt-get install libncurses5-dev
sudo apt-get install libncursesw5
sudo make install

Now my Powertop output looks much more normal!

Cn                Avg residency       P-states (frequencies)
C0 (cpu running)        ( 7.6%)       Turbo Mode     5.5%
polling           2.3ms ( 0.0%)         2.71 Ghz     0.3%
C1 mwait          0.3ms ( 1.2%)         1.80 Ghz     0.1%
C2 mwait          0.6ms ( 0.9%)         1000 Mhz     0.2%
C3 mwait          1.0ms ( 0.1%)          800 Mhz    93.5%
C4 mwait          3.5ms (90.0%)
Wakeups-from-idle per second : 312.1    interval: 10.0s
no ACPI power usage estimate available

Top causes for wakeups:
  38.9% (456.2)   [Rescheduling interrupts] <kernel IPI>
  12.2% (143.0)D  kworker/0:1
  10.0% (117.0)   [i915] <interrupt>
   8.5% ( 99.1)   npviewer.bin
   7.2% ( 84.1)   [kernel scheduler] Load balancing tick
   7.2% ( 84.0)   kworker/0:0
   3.6% ( 42.7)   [iwlagn] <interrupt>
   2.8% ( 32.8)   fingerprint-pol
   2.2% ( 26.2)D  firefox
   2.2% ( 25.9)   [Function call interrupts] <kernel IPI>
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.