Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently my file server suffered a hardware failure; long story short, I just finished putting a brand new motherboard, CPU, and RAM into it. And happily everything is working fine -- except the eSATA.

Specifically, the eSATA port doesn't seem to recognize when I unplug my drive, or plug in a different one. On the previous hardware, I could unplug the drive and watch its entry in e.g. /dev/disk/by-id/ disappear, and I could plug in a different drive and watch a new entry appear in the same directory.

Now, however, I unplug the drive, and the entry doesn't disappear. I plug in a different drive, and there's no new entry, only the old one. Strangely, though, fdisk -l reads the new drive just fine; the issue, though, is that I have a backup script that relies on those drive IDs to find and mount the (encrypted) external backup drive.

The new motherboard is an ASRock 880G Pro3 sporting an AMD Athlon II X2 250. I have turned on AHCI mode for the SATA controller, and I've tried the "AMD AHCI BIOS" (although I have no idea what this actually is) both enabled and disabled, to no effect.

Is there some recongifuration I need to do to the kernel, or to the package, to make it properly recognize these signals on the new hardware? Or some setting that I'm missing in the BIOS or something?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Further tinkering has inadvertently lead me to the solution -- in addition to changing the SATA mode to AHCI, I had to also disable "SATA IDE Combined Mode"; I've also left disabled "AMD AHCI BIOS ROM", however I have not tested if that is necessary or not for proper detection of hot-swap events.

Seems really odd to me that such a basic functionality as hot-swappable eSATA depends upon first finding the proper group of settings to enable and disable in the BIOS (wasn't necessary to tweak anything on my previous motherboard, it just worked right out of the box), but there it is.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.