Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to mount a unionfs file system in fstab (as one of the steps in this guide), with the following line:

unionfs /usr unionfs nodev,noatime,dirs=/.filesystems/usr/overlay=ro:/usr=rw 0 0

I've installed the package unionfs-fuse and added unionfs to /etc/modules, but when trying to mount -a I still get an error saying

mount: unknown file system type: unionfs

What am I doing wrong here?

share|improve this question
I wanted to tag this unionfs, but I don't have enough rep to create new tags. Anyone with 300+, feel free =) – Tomas Lycken Oct 24 '11 at 1:03
up vote 3 down vote accepted

I've solved (or rather worked around) this, by not using unionfs and instead using aufs - another union file system.

Install the AUFS package and its kernel module from linux-image-extra-virtual:

sudo apt-get install aufs-tools linux-image-extra-virtual

The corresponding row in my fstab now looks like this:

usr    /usr    aufs    udba=reval,br:/.filesystems/usr/rw:/.filesystems/usr/ro    0   0

The squashfs is mounted at /.filesystems/usr/ro in the previous line, making this working as a substitute for the troubling steps in the guide I referred to in the OP.

share|improve this answer
That didn't solve it for me, I got the same unknown FS error with AUFS. – Enkouyami Jul 18 '15 at 17:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.