Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm sometimes having trouble authenticating and it seems I'm no longer a member of the 'admin' group. Or I am.... but I have two user accounts with the same name and only one of them is... or something equally weird...

When I start my terminal, the command prompt says I'm myself (user 'casey'):

casey@netbook:~$

When I run the groups command without a user argument... ("man groups" sez "if no USERNAME is specified, [groups are printed] for the current process") ... it says I'm a member of only two groups: 'casey' and 'lock'!

casey@netbook:~$ groups
casey lock

If I do specify my username, I suddenly see I'm a member of many groups:

casey@netbook:~$ groups casey
casey : casey adm dialout cdrom floppy audio dip video plugdev fuse lpadmin admin sambashare lock

These are the same groups I see if I su to my own username, and again query groups with no arguments. Notice that the prompt username stays the same:

casey@netbook:~$ su casey
casey@netbook:~$ groups
casey adm dialout cdrom floppy audio dip video plugdev fuse lpadmin admin sambashare lock

But if I exit again:

casey@netbook:~$ exit
exit
casey@netbook:~$ groups
casey lock

Output of users:

casey@netbook:~$ users
casey casey

Example of trouble authenticating:

casey@netbook:~$ gksudo gedit /etc/passwd

This yielded the following error dialog:

Failed to run gedit '/etc/passwd' as user root. The underlying authorization mechanism (sudo) does not allow you to run this program. Contact the system administrator.

Continued:

casey@netbook:~$ su root
root@netbook:/home/casey# gedit /etc/passwd
(gedit:19566): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported
**
GLib-GIO:ERROR:/build/buildd/glib2.0-2.28.6/./gio/gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
Aborted
root@netbook:/home/casey# su casey
casey@netbook:~$ gksudo gedit /etc/passwd

At this point it launched properly. /-:

Background info: I'm using Natty Narwhal 11.04. All was normal until the other day when I tried to install "Vodafone Mobile Connect", which complained I wasn't a member of groups 'dialout' and 'lock'. I added myself, but it still said the same thing. I copied and pasted a proposed solution from a web-page which google translate had mischievously inserted extra spaces into: sudo chmod 0660 / etc / ppp / pap-secrets / etc / ppp / chap-secrets. ::forehead-slap:: This screwed up permissions non-recursively (thank goodness for that!) on the root directory of my file system. It was an easy fix with another chmod from my live USB stick. I don't think this is related to my current problem, but worth mentioning just in case. Incidentally, I can't seem to remove the 'lock' group from the one 'casey' account, nor add it to the other.

share|improve this question
add comment

2 Answers 2

It's completely normal for the system to display you as more than one user. That usually means you have two terminals open. If you open more, then it'll show more. Use the w command to display more info about each session.

groups and groups username is supposed to display similar results, though. Strange issue. Perhaps you can check /etc/passwd to see if you're listed twice?

share|improve this answer
    
Thanks for the feedback about users, and the suggestion. I checked, and I'm just listed once in /etc/passwd. –  Casey Jones Oct 24 '11 at 1:12
    
I tried w from the initial terminal session and again after suing to 'casey' -- the output is identical (besides timestamps and metrics). –  Casey Jones Oct 24 '11 at 1:45
add comment

Well, I wish I could say what the problem had been... But after several (not just one or two, but several) more reboots, the problem randomly went away (Windows-style). Now I can authenticate normally and all.

Sadly nonetheless, although I now seem to be one single, monolithic user belonging to both 'dialout' and 'lock' groups, Vodafone Mobile Connect's 'twistd' component still complains:

It appears that you do not have privillages [sic] to run the Vodafone Mobile Connect application. You need to be part of the groups 'dialout' and 'lock' to run the Modem Manager. If you have already added yourself to those groups, try restarting the computer or logging in as yourself to activate your changes.

But whatever. My major operating system issues are in order, so I'll just continue living without an SMS manager in Ubuntu and keep booting to Windows for that. I haven't been able to get Wammu, BitPIM, or Gnome Phone Manager (based on gnokii) working for my USB modem (Huawei E1550) either. d-:

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.