Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I installed fuse, and added myself to fuse usergroup. The directory somefolder is already created. When I run the command, it asks for the remote password, and if I enter it correctly, prints nothing else, and seems like it worked.

However, I cannot access somefolder, and in krusader somefolder looks like a file now, not like a directory. I cannot even change permissions on somefolder anymore, not even with sudo... How to make it work?

share|improve this question

closed as too localized by Jorge Castro, jokerdino, Bruno Pereira, Takkat, htorque Jan 27 '12 at 2:05

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Nope, have tried it now, and it does the same thing... Also note that before I run the command, somefolder is a legitimate empty directory. After the command that changes (into a file/something unreadable), so it sure seems like it finds the right inode to change. –  Cray Oct 23 '11 at 23:27
Have you had sshfs work before? Do you own the '/' directory on the remote end? –  belacqua Oct 23 '11 at 23:29
Well it worked with another more remote server, where it mounted the directory and I could see the list of files. But that was some time ago, so some settings in my system or somethink like that could have changed. Is there any log for sshfs that I can maybe check? –  Cray Oct 23 '11 at 23:31
I'm not sure, but you might look in /var/log/syslog. Running with the -o sshfs_debug flag for debug output might give something useful. But if it's a permissions problem, everything is working as expected from the point of view of the mount behavior. –  belacqua Oct 23 '11 at 23:36
If someuser has not the permission 'x' on / on the remote computer, he is not allowed to list the directory contents. Using a local root user will change nothing on this permission issue. Can you try to mount: someuser@ ? This should work if the user has a home directory on the remote machine. –  Michael K Oct 24 '11 at 6:07

Browse other questions tagged or ask your own question.