Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is a new installation of Ubuntu 11.10 on an acer aspire 3630. The cd drive is broken so I had to install Ubuntu over network (and I suspect it did not install all the packages in the normal installation).

The problem is that ubuntu does not list the available wireless connections and I can't manually connect to my home wifi. I have tried a lot of things and this is all the info I have:

The wireless card is an AR2413.

The physical button to switch on/off the wireless does not work.

I am using the ath5k driver.

During boot I get the following message:

ADDRCONF(NETDEV_UP): wlan0: link is not ready

iwconfig

lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

lshw

*-network:1
   description: Wireless interface
   product: AR2413 802.11bg NIC
   vendor: Atheros Communications Inc.
   physical id: b
   bus info: pci@0000:00:0b.0
   logical name: wlan0
   version: 01
   serial: 00:16:ce:17:eb:4c
   width: 32 bits
   clock: 33MHz
   capabilities: pm bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=ath5k driverversion=3.0.0-12-generic firmware=N/A latency=168 link=no maxlatency=28 mingnt=10 multicast=yes wireless=IEEE 802.11bg
   resources: irq:17 memory:e2010000-e201ffff

rfkill list all

rfkill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

UPDATE

I discovered that the problem is that, when I boot Ubuntu the wireless is disabled. If I manually enable it it works perfectly... Until the next time I restart the computer. These are the commands I use to enable the wireless card:

sudo rmmod -f ath5k
sudo rfkill unblock all
sudo modprobe ath5k
share|improve this question
    
That is not the problem; read the update. –  miguelSantirso Oct 24 '11 at 21:42

2 Answers 2

You should be able to add those commands listed in your update, to /etc/rc.local to have them run at start up.

share|improve this answer
    
The commands require the super user password, so I don't know what would happen if I add them to the rc.local file. –  miguelSantirso Nov 5 '11 at 17:40
    
commands run from /etc/rc.local are run as root as a part of booting. –  bodhi.zazen Feb 29 '12 at 6:22

Speculative answer:

There is an old bug-report on launchpad, with the last update saying that this issue occurred in Natty. Maybe this still hasn't been resolved in Oneiric.

Solution was:

sudo nano /etc/modprobe.d/modprobe.conf 

add to the bottom of the file:

options ath5k nohwcrypt

Save and reboot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.